summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJim Jagielski <jim@apache.org>2013-12-20 18:48:14 +0000
committerJim Jagielski <jim@apache.org>2013-12-20 18:48:14 +0000
commitd6e91afa0c1153ace878aa45c82cdb06d12520ff (patch)
tree0f6da4972de4cbf0776fb0302cfa0870431ffe95 /configure.in
parentd7dd87bf21da03c3728fb883825a27cff7519834 (diff)
downloadhttpd-d6e91afa0c1153ace878aa45c82cdb06d12520ff.tar.gz
For *bsd* systems, see if we are using BSD make and,
if so, then use that format for include/ifdef/else/endif git-svn-id: https://svn.apache.org/repos/asf/httpd/httpd/trunk@1552779 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5f469a31e5..074cfd14b4 100644
--- a/configure.in
+++ b/configure.in
@@ -909,24 +909,35 @@ if test "x$perlbin" = "x"; then
fi
AC_SUBST(perlbin)
-dnl If we are running on BSD/OS, we need to use the BSD .include syntax.
+dnl If we are running on a BSD variant, see if we need to use the BSD .include syntax.
BSD_MAKEFILE=no
ap_make_include=include
+ap_make_ifdef=ifdef
+ap_make_else=else
+ap_make_endif=endif
ap_make_delimiter=' '
case $host in
-*bsdi*)
+*bsd*)
# Check whether they've installed GNU make
if make --version > /dev/null 2>&1; then
true
else
BSD_MAKEFILE=yes
ap_make_include=.include
+ ap_make_ifdef=.ifdef
+ ap_make_else=.else
+ ap_make_endif=.endif
ap_make_delimiter='"'
fi
;;
esac
+AC_MSG_NOTICE([using BSD Makefile syntax... $BSD_MAKEFILE])
+
AC_SUBST(ap_make_include)
+AC_SUBST(ap_make_ifdef)
+AC_SUBST(ap_make_else)
+AC_SUBST(ap_make_endif)
AC_SUBST(ap_make_delimiter)
dnl Ensure that docs/conf is created.