summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3da3fcb53b..e630d112d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -977,11 +977,11 @@ SET(rel_runtimedir "logs")
SET(rel_sysconfdir "conf")
FILE(GLOB_RECURSE conffiles RELATIVE ${CMAKE_SOURCE_DIR}/docs/conf "docs/conf/*")
FOREACH(template ${conffiles})
- STRING(REPLACE ".conf.in" ".conf" conf ${template})
+ STRING(REPLACE ".conf.in" ".conf" conf "${template}")
FILE(READ "docs/conf/${template}" template_text)
IF(template MATCHES ".conf.in$")
# substitute @var@/@@var@@ in .conf.in
- STRING(REPLACE "@@" "@" template_text ${template_text})
+ STRING(REPLACE "@@" "@" template_text "${template_text}")
STRING(CONFIGURE "${template_text}" template_text @ONLY)
ENDIF()
FILE(WRITE ${CMAKE_BINARY_DIR}/conf/original/${conf} "${template_text}")