summaryrefslogtreecommitdiff
path: root/libappstream-builder/meson.build
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2022-06-07 09:43:17 +0100
committerRichard Hughes <richard@hughsie.com>2022-06-08 08:05:43 +0100
commitb6cb98ee0f1fefc5831d9e3b63b727414a750567 (patch)
tree023070279c877678a93217081ea00b859a882269 /libappstream-builder/meson.build
parentc6c37d096f3d236e86c3073a58f7836298b05faa (diff)
downloadappstream-glib-b6cb98ee0f1fefc5831d9e3b63b727414a750567.tar.gz
Port from libsoup to libcurl
The former bumped ABI, and all sorts of crazy happens when you link in libappstream-glib into a process with the 'other' ABI. It seems the universe has settled on curl as a dep; do the same.
Diffstat (limited to 'libappstream-builder/meson.build')
-rw-r--r--libappstream-builder/meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/libappstream-builder/meson.build b/libappstream-builder/meson.build
index 79e8a74..2c7824c 100644
--- a/libappstream-builder/meson.build
+++ b/libappstream-builder/meson.build
@@ -6,11 +6,10 @@ asbuilder_cargs = [
]
deps = [
- glib,
+ gio,
gmodule,
gdkpixbuf,
libarchive,
- soup,
]
if get_option('dep11')
@@ -68,7 +67,7 @@ asb_self_test = executable(
include_directories('..'),
asglib_incdir,
],
- dependencies : [glib, gdkpixbuf, soup],
+ dependencies : [gio, gdkpixbuf],
c_args : cargs + [
'-DTESTDIRSRC="@0@/../data/tests"'.format(meson.current_source_dir()),
'-DTESTDIRBUILD="@0@/../data/tests"'.format(meson.current_build_dir()),