summaryrefslogtreecommitdiff
path: root/libappstream-glib/meson.build
diff options
context:
space:
mode:
authorOleksii Samorukov <samm@os2.kiev.ua>2020-01-17 15:59:38 +0100
committerRichard Hughes <richard@hughsie.com>2020-01-17 15:42:14 +0000
commitb5d626fcaa281685be065f1ce01beb0786780511 (patch)
treeadb16a24623f9ec32b83982105c34c953e0e1ac1 /libappstream-glib/meson.build
parent65d4ed454b81c1ed00a24fbee9b8c95b6a664aaf (diff)
downloadappstream-glib-b5d626fcaa281685be065f1ce01beb0786780511.tar.gz
Support versioning on clang/macOS
Diffstat (limited to 'libappstream-glib/meson.build')
-rw-r--r--libappstream-glib/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/libappstream-glib/meson.build b/libappstream-glib/meson.build
index cef815d..715123d 100644
--- a/libappstream-glib/meson.build
+++ b/libappstream-glib/meson.build
@@ -134,7 +134,13 @@ sources = sources + [astagpriv]
install_headers(headers, subdir : 'libappstream-glib')
mapfile = 'appstream-glib.map'
-vflag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), mapfile)
+if platform_osx
+ mapfile = 'appstream-glib.map.osx-clang'
+ vflag = '-Wl,-exported_symbols_list,@0@/@1@'.format(meson.current_source_dir(), mapfile)
+else
+ vflag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), mapfile)
+endif
+
asglib = shared_library(
'appstream-glib', sources,
soversion : lt_current,