summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw AT waldmann-edv DOT de>2011-03-26 22:02:29 +0100
committerThomas Waldmann <tw AT waldmann-edv DOT de>2011-03-26 22:02:29 +0100
commit27f869a2fe100b10bee417503fa18bb7659c45d7 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /setup.py
parent8deba97933cbf8c7424b6e75d167e009d6deddb7 (diff)
downloadargparse-27f869a2fe100b10bee417503fa18bb7659c45d7.tar.gz
licensing issues: we need a clean restart here - remove everything
Problem: argparse has been licensed under Apache License v2.0 While this license is a FOSS license, it has known compatibility issues with the GNU GPL v2 - projects under GPL v2 can't use code under apache license v2.0. Projects which use "GPL v2 (or, at user's choice, any later version)" only have one means using code under apache license v2.0: to choose the "or any later" part and go GPL v3. Of course, this would cause issues with other license.... As argparse was contributed to the Python v2.7 code base, it is available under the Python License, which has no such compatibility issue. Thus, a clean solution for the argparse package (for users who need argparse for projects which have to support python older than 2.7) is to remove all old apache licensed files and start from scratch using the python-licensed code from the standard library.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py54
1 files changed, 0 insertions, 54 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index 95a8a0d..0000000
--- a/setup.py
+++ /dev/null
@@ -1,54 +0,0 @@
-# -*- coding: utf-8 -*-
-
-# Copyright © 2006-2009 Steven J. Bethard <steven.bethard@gmail.com>.
-#
-# Licensed under the Apache License, Version 2.0 (the "License"); you may not
-# use this file except in compliance with the License. You may obtain a copy
-# of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
-# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
-# License for the specific language governing permissions and limitations
-# under the License.
-
-import argparse
-import distutils.core
-import os
-import re
-
-
-def read_description():
- readme_file = open(os.path.join(os.path.dirname(__file__), 'README.txt'))
- readme_text = readme_file.read()
- readme_file.close()
- main_desc_regexp = r'^argparse\s*[\w.]*\s*\n=======+\s*\n(.*)Requirements '
- main_desc_re_c = re.compile(main_desc_regexp, re.DOTALL)
- main_desc, = main_desc_re_c.findall(readme_text)
- avail_desc_regexp = r'Availability & Documentation\s*\n-----+\s*\n(.*)'
- avail_desc_re_c = re.compile(avail_desc_regexp, re.DOTALL)
- avail_desc, = avail_desc_re_c.findall(readme_text)
- return main_desc + avail_desc
-
-distutils.core.setup(
- name='argparse',
- version=argparse.__version__,
- author='Steven Bethard',
- author_email='steven.bethard@gmail.com',
- url='http://code.google.com/p/argparse/',
- description='Python command-line parsing library',
- long_description = read_description(),
- license='Apache 2.0',
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Topic :: Software Development',
- ],
- py_modules=['argparse'],
-)