summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorsteven.bethard <devnull@localhost>2009-03-27 16:05:43 +0000
committersteven.bethard <devnull@localhost>2009-03-27 16:05:43 +0000
commit764481166472476a826d3791c1fd4e13a927a526 (patch)
tree231bb2315ec8b4aa90c47c1bb01d6f3c86281976 /setup.py
parentd7a0b852621b4672983d12e6b4ad8425a0bc8cbe (diff)
downloadargparse-764481166472476a826d3791c1fd4e13a927a526.tar.gz
Initial import from python-hosting.com repository.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..d6492fc
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,38 @@
+# -*- coding: utf-8 -*-
+
+# Copyright © 2006-2009 Steven J. Bethard <steven.berthard@gmail.com>.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted under the terms of the 3-clause BSD
+# license. No warranty expressed or implied.
+# For details, see the accompanying file LICENSE.txt.
+
+import textwrap
+import distutils.core
+
+distutils.core.setup(
+ name='argparse',
+ version='0.9.0',
+ author='Steven Bethard',
+ author_email='steven.bethard@gmail.com',
+ url='http://argparse.python-hosting.com/',
+ description='An optparse-inspired command-line parsing library',
+ long_description = textwrap.dedent("""\
+ Argparse takes the best of the optparse command-line parsing module
+ and brings it new life. Argparse adds positional as well as
+ optional arguments, the ability to create parsers for sub-commands,
+ more informative help and usage messages, and much more. At the
+ same time, it retains the ease and flexibility of use that made
+ optparse so popular."""),
+ license='BSD',
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development',
+ ],
+ py_modules=['argparse'],
+)