summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorsteven.bethard <devnull@localhost>2009-05-04 05:20:50 +0000
committersteven.bethard <devnull@localhost>2009-05-04 05:20:50 +0000
commitda2a4da94bdb285c7b568e4fd0e546577e446f33 (patch)
treedb2e973157287c0c17eb1fb1cb00ce01f4d8a152 /setup.py
parentc8ced44d922425227df2601912402835563801f3 (diff)
downloadargparse-da2a4da94bdb285c7b568e4fd0e546577e446f33.tar.gz
Make append* actions copy their default value.
Bump version numbers, and clean up description text in setup.py. Ignore some generated and local files.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 6 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 448f866..976b3c6 100644
--- a/setup.py
+++ b/setup.py
@@ -16,21 +16,19 @@
import textwrap
import distutils.core
+import argparse
distutils.core.setup(
name='argparse',
- version='0.9.1',
+ version=argparse.__version__,
author='Steven Bethard',
author_email='steven.bethard@gmail.com',
url='http://code.google.com/p/argparse/',
- description='An optparse-inspired command-line parsing library',
+ description='Python command-line parsing library',
long_description = textwrap.dedent("""\
- Argparse takes the best of the optparse command-line parsing module
- and brings it new life. Argparse adds positional as well as
- optional arguments, the ability to create parsers for sub-commands,
- more informative help and usage messages, and much more. At the
- same time, it retains the ease and flexibility of use that made
- optparse so popular."""),
+ The argparse module provides an easy, declarative interface for
+ creating command line tools.
+ """),
license='Apache 2.0',
classifiers=[
'Development Status :: 4 - Beta',