summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Habets <thomas@habets.pp.se>2010-04-02 13:42:47 +0200
committerThomas Habets <thomas@habets.pp.se>2010-04-02 13:42:47 +0200
commit34ace21f5d654f2eb6dc45ab06b4efe00655bfb5 (patch)
tree2a5d25625fe6c9503a7025ff48ab97f73970ff51 /configure.ac
parentdf36995363d6b92d635d353a55ba4b51ce004b5a (diff)
downloadarping-34ace21f5d654f2eb6dc45ab06b4efe00655bfb5.tar.gz
changed ping_recv_unix to use clock_gettime() instead of gettimeofday()
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b42253..0f43c28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,7 @@ AC_PROG_MAKE_SET
# Checks for libraries.
AC_CHECK_LIB([socket], [socket])
AC_CHECK_LIB([nsl], [gethostbyname])
+AC_CHECK_LIB([rt], [clock_gettime])
AC_CHECK_LIB([net], [libnet_name_resolve],
[AC_MSG_ERROR([libnet 1.0.x found. Arping 2.x requires libnet 1.1.x])])
AC_CHECK_LIB([net], [libnet_init], ,[AC_MSG_ERROR([libnet 1.1.x not found])])