summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Habets <habets@google.com>2017-10-03 10:50:47 +0100
committerThomas Habets <habets@google.com>2017-10-03 10:50:47 +0100
commit77944d8b1dd7d7d16cd8b365f3e4cc6ff2d3fbba (patch)
treef4cf09094d168adedf1394934623f3ce552acf97 /configure.ac
parent52b8d05ae62301c698488445666ad4604d9fe2b6 (diff)
downloadarping-77944d8b1dd7d7d16cd8b365f3e4cc6ff2d3fbba.tar.gz
Further simplify CLOCK_MONOTONIC check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 126a37f..105e120 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,16 +112,14 @@ fi
# check for CLOCK_MONOTONIC
-AC_CHECK_DECL([CLOCK_MONOTONIC],
- [ ac_cv_have_clock_monotonic="yes" ],
- [ ac_cv_have_clock_monotonic="no" ],
+AC_CHECK_DECL([CLOCK_MONOTONIC], [], [],
[
#include <time.h>
#include <sys/time.h>
]
)
-AM_CONDITIONAL(HAVE_CLOCK_MONOTONIC, test x$ac_cv_have_clock_monotonic = xyes)
-if test x$ac_cv_have_clock_monotonic = xyes; then
+AM_CONDITIONAL(HAVE_CLOCK_MONOTONIC, test x$ac_cv_have_decl_CLOCK_MONOTONIC = xyes)
+if test x$ac_cv_have_decl_CLOCK_MONOTONIC = xyes; then
AC_DEFINE([HAVE_CLOCK_MONOTONIC], [1], [Monotonic clock])
fi