summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatthew Peveler <matt.peveler@gmail.com>2020-06-05 00:19:45 -0400
committerMatthew Peveler <matt.peveler@gmail.com>2021-01-28 02:37:16 +0000
commitb13131d4564e26c77d3ffd9d585145acafd38021 (patch)
tree683e4ee5ad0bdc5f5cb480bcec92faf6aac15a97 /setup.py
parent9003da54d47140bbd0bba64be103ff175f4d571b (diff)
downloadasciidoc-git-b13131d4564e26c77d3ffd9d585145acafd38021.tar.gz
use pip/setup.py to install asciidoc
Signed-off-by: Matthew Peveler <matt.peveler@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 3 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index bcf2d5e..2f053c6 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,6 @@
# Note: To use the 'upload' functionality of this file, you must:
# $ pip install twine
-import io
import os
import sys
from shutil import rmtree
@@ -16,24 +15,10 @@ NAME = 'asciidoc'
DESCRIPTION = 'AsciiDoc is a text document format for writing things.'
URL = 'https://github.com/asciidoc/asciidoc-py3'
AUTHOR = 'asciidoc team'
-REQUIRES_PYTHON = '>=3.4.0'
-
-# The rest you shouldn't have to touch too much :)
-# ------------------------------------------------
-# Except, perhaps the License and Trove Classifiers!
-# If you do change the License, remember to change the Trove Classifier
-# for that!
+REQUIRES_PYTHON = '>=3.5.0'
here = os.path.abspath(os.path.dirname(__file__))
-# Import the README and use it as the long-description.
-# Note: this will only work if 'README.md' is present in your MANIFEST.in file!
-try:
- with io.open(os.path.join(here, 'README.md'), encoding='utf-8') as f:
- long_description = '\n' + f.read()
-except FileNotFoundError:
- long_description = DESCRIPTION
-
# Load the package's __metadata__.py module as a dictionary.
about = {}
with open(os.path.join(here, NAME, '__metadata__.py')) as f:
@@ -84,7 +69,8 @@ setup(
name=NAME,
version=about['__version__'],
description=DESCRIPTION,
- long_description=long_description,
+ long_description=open(os.path.join(here, 'README')),
+ long_description_content_type='text/markdown', # This is important!
author=AUTHOR,
python_requires=REQUIRES_PYTHON,
url=URL,