summaryrefslogtreecommitdiff
path: root/atk/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2017-09-12 12:19:37 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2017-09-13 23:21:06 +0800
commit271d9e4127fed5db8b85ced59ac15748e49ea287 (patch)
treeaaceee63b05c3db70e6d695f6ab759a060184d58 /atk/meson.build
parent28f3e78e0ca0d5eb36d00fd8aef89eb0d1bacc93 (diff)
downloadat-spi2-core-271d9e4127fed5db8b85ced59ac15748e49ea287.tar.gz
build: Add option to disable introspection
This adds an option to Meson builds to disable introspection builds even when GObject-Introspection is installed. Introspection is still enabled by default. https://bugzilla.gnome.org/show_bug.cgi?id=785802
Diffstat (limited to 'atk/meson.build')
-rw-r--r--atk/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/atk/meson.build b/atk/meson.build
index 95942e0b..7b5a683d 100644
--- a/atk/meson.build
+++ b/atk/meson.build
@@ -137,7 +137,9 @@ libatk_dep = declare_dependency(link_with: libatk,
dependencies: gobject_dep,
sources: atk_enum_h)
-if not meson.is_cross_build()
+disable_introspection = get_option('disable_introspection')
+
+if not meson.is_cross_build() and not disable_introspection
gnome.generate_gir(libatk,
sources: atk_sources + atk_headers + [ atk_enum_h ] + [ atk_version_h ],
namespace: 'Atk',