summaryrefslogtreecommitdiff
path: root/atk/meson.build
diff options
context:
space:
mode:
authorAntonio Ospite <ao2@ao2.it>2020-03-15 23:18:24 +0100
committerAntonio Ospite <ao2@ao2.it>2020-08-19 23:53:58 +0200
commit5541b4fafe612c44de8d8604afe4dab137702f9f (patch)
treee6fd8e80f69dbb697a4ef9bd5db46ad56cc0c490 /atk/meson.build
parentd84ddda9106ca78c815a91aa9e9524533245373f (diff)
downloadat-spi2-core-5541b4fafe612c44de8d8604afe4dab137702f9f.tar.gz
meson: fix pkg-config generation with internal dependencies
When building with internal dependencies (subprojects) meson fails to configure the build with the following message: subprojects/atk/atk/meson.build:161:10: ERROR: requires argument not a string, library with pkgconfig-generated file or pkgconfig-dependency object, got <InternalDependency null: True> Use libraries instead of requires when calling pkgconfig.generate() to make the configuration succeed. Change inspired by https://gitlab.freedesktop.org/libnice/libnice/commit/ff75be1b19fc2599fda520321649da32625c561d
Diffstat (limited to 'atk/meson.build')
-rw-r--r--atk/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/atk/meson.build b/atk/meson.build
index 5dd736ab..d19bbbac 100644
--- a/atk/meson.build
+++ b/atk/meson.build
@@ -164,5 +164,5 @@ pkgconfig.generate(libatk,
description: 'Accessibility Toolkit',
subdirs: atk_api_name,
filebase: 'atk',
- requires: glib_dep,
+ libraries: glib_dep,
)