summaryrefslogtreecommitdiff
path: root/atk/meson.build
diff options
context:
space:
mode:
authorThomas Booker <tw.booker@outlook.com>2022-09-10 14:11:44 +1200
committerCoderThomasB <tw.booker@outlook.com>2022-09-28 09:37:27 +1300
commit837c050e48ea73f6dcf5ef9ff7120bc7da8b38ad (patch)
tree63f04cc81df87161f3d3c1ad5122b04a64741bc1 /atk/meson.build
parent35bcba928650b415b4d8a572b4d9b19384234ee6 (diff)
downloadat-spi2-core-837c050e48ea73f6dcf5ef9ff7120bc7da8b38ad.tar.gz
Docs: Move to gi-docgen
Diffstat (limited to 'atk/meson.build')
-rw-r--r--atk/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/atk/meson.build b/atk/meson.build
index e99160e3..d216b680 100644
--- a/atk/meson.build
+++ b/atk/meson.build
@@ -138,7 +138,7 @@ libatk = library(atk_api_name,
atk_sources_dep = [ atk_enum_h ]
if have_gir
- atk_sources_dep += gnome.generate_gir(libatk,
+ atk_gir = gnome.generate_gir(libatk,
sources: atk_sources + atk_headers + [ atk_enum_h ] + [ atk_version_h ],
namespace: 'Atk',
nsversion: atk_api_version,
@@ -153,6 +153,8 @@ if have_gir
'-DATK_COMPILATION',
],
)
+
+ atk_sources_dep += atk_gir
endif
libatk_dep = declare_dependency(link_with: libatk,