summaryrefslogtreecommitdiff
path: root/atk/meson.build
diff options
context:
space:
mode:
authormaxice8 <thinkabit.ukim@gmail.com>2019-01-29 13:12:48 -0200
committermaxice8 <thinkabit.ukim@gmail.com>2019-01-29 13:12:48 -0200
commitdb2d7a6d3c45fe57420d5e5aa8d8509c52943e6e (patch)
treebda998b055d25f8177a563a64704e222354f2681 /atk/meson.build
parent1a7e3d0fc9666e02d0cddc6f856c3dfcfad19910 (diff)
downloadat-spi2-core-db2d7a6d3c45fe57420d5e5aa8d8509c52943e6e.tar.gz
atk/meson.build: do not guard gir behind a cross_build check.
People that are cross-building are very likely to set the introspection option to false themselves.
Diffstat (limited to 'atk/meson.build')
-rw-r--r--atk/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/atk/meson.build b/atk/meson.build
index 69ba6c5c..809a48d6 100644
--- a/atk/meson.build
+++ b/atk/meson.build
@@ -137,7 +137,7 @@ libatk_dep = declare_dependency(link_with: libatk,
dependencies: glib_dep,
sources: atk_enum_h)
-if not meson.is_cross_build() and get_option('introspection')
+if get_option('introspection')
gnome.generate_gir(libatk,
sources: atk_sources + atk_headers + [ atk_enum_h ] + [ atk_version_h ],
namespace: 'Atk',