summaryrefslogtreecommitdiff
path: root/bus/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'bus/meson.build')
-rw-r--r--bus/meson.build53
1 files changed, 26 insertions, 27 deletions
diff --git a/bus/meson.build b/bus/meson.build
index 22a1bce6..2f3c5621 100644
--- a/bus/meson.build
+++ b/bus/meson.build
@@ -46,39 +46,38 @@ launcher_args = [
'-DDATADIR="@0@"'.format(atspi_datadir),
]
-if get_option('dbus_daemon') != 'default'
- launcher_args += '-DDBUS_DAEMON="@0@"'.format(get_option('dbus_daemon'))
-else
- dbus_daemon = find_program('dbus-daemon',
- '/sbin/dbus-daemon',
- '/usr/sbin/dbus-daemon',
- '/libexec/dbus-daemon',
- '/usr/libexec/dbus-daemon',
- '/usr/lib/dbus-daemon',
- '/usr/pkg/bin/dbus-daemon',
- required: false)
- if dbus_daemon.found()
- launcher_args += '-DDBUS_DAEMON="@0@"'.format(dbus_daemon.full_path())
- endif
-endif
-
needs_systemd = false
-if get_option('dbus_broker') != 'default'
- launcher_args += '-DDBUS_BROKER="@0@"'.format(get_option('dbus_broker'))
- needs_systemd = true
+if get_option('default_bus') == 'dbus-daemon'
+ if get_option('dbus_daemon') != 'default'
+ launcher_args += '-DDBUS_DAEMON="@0@"'.format(get_option('dbus_daemon'))
+ else
+ dbus_daemon = find_program('dbus-daemon',
+ '/sbin/dbus-daemon',
+ '/usr/sbin/dbus-daemon',
+ '/libexec/dbus-daemon',
+ '/usr/libexec/dbus-daemon',
+ '/usr/lib/dbus-daemon',
+ '/usr/pkg/bin/dbus-daemon',
+ required: false)
+ if dbus_daemon.found()
+ launcher_args += '-DDBUS_DAEMON="@0@"'.format(dbus_daemon.full_path())
+ endif
+ endif
else
- dbus_broker = find_program('dbus-broker-launch',
- required: false)
- if dbus_broker.found()
- launcher_args += '-DDBUS_BROKER="@0@"'.format(dbus_broker.full_path())
+ launcher_args += '-DWANT_DBUS_BROKER'
+ if get_option('dbus_broker') != 'default'
+ launcher_args += '-DDBUS_BROKER="@0@"'.format(get_option('dbus_broker'))
needs_systemd = true
+ else
+ dbus_broker = find_program('dbus-broker-launch',
+ required: false)
+ if dbus_broker.found()
+ launcher_args += '-DDBUS_BROKER="@0@"'.format(dbus_broker.full_path())
+ needs_systemd = true
+ endif
endif
endif
-if get_option('default_bus') == 'dbus-broker'
- launcher_args += '-DWANT_DBUS_BROKER'
-endif
-
if needs_systemd
systemd_dep = dependency('libsystemd')
else