summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-05-22 21:11:30 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-22 21:11:30 +0100
commitb54a6abd89710fb0956ca0b121b7358d777d3358 (patch)
treefcd4d31e7d5869f0a8e4c471f87b8ad625a2a959 /meson.build
parent08b16a21c004e5663b3e7362fcf6c3ff981d9f43 (diff)
downloadatk-b54a6abd89710fb0956ca0b121b7358d777d3358.tar.gz
meson: Use the appropriate soversion
The shared library should have a soversion of 0, so that Meson can create the appropriate symlinks to match what Autotools do.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1fd2ed5..af9b3dd 100644
--- a/meson.build
+++ b/meson.build
@@ -35,7 +35,8 @@ atk_conf.set_quoted('VERSION', meson.project_version())
atk_conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
# Maintain version scheme with libtool
-atk_soversion = '0.@0@.@1@'.format((atk_binary_age - atk_interface_age), atk_interface_age)
+atk_soversion = 0
+atk_libversion = '@0@.@1@.@2@'.format(atk_soversion, (atk_binary_age - atk_interface_age), atk_interface_age)
add_project_arguments([ '-DG_DISABLE_SINGLE_INCLUDES', '-DATK_DISABLE_SINGLE_INCLUDES' ], language: 'c')