summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 2 insertions, 18 deletions
diff --git a/meson.build b/meson.build
index daf5b30..b03e189 100644
--- a/meson.build
+++ b/meson.build
@@ -20,6 +20,7 @@ atk_interface_age = 1
atk_binary_age = 10000 * atk_major_version + 100 * atk_minor_version + 10 + atk_micro_version
atk_api_version = '1.0'
+atk_api_name = 'atk-@0@'.format(atk_api_version)
atk_api_path = 'atk-@0@/atk'.format(atk_api_version)
atk_prefix = get_option('prefix')
@@ -94,24 +95,7 @@ gobject_req_version = '>= 2.31.2'
gobject_dep = dependency('gobject-2.0', version: gobject_req_version)
-# Compat variables for pkgconfig
-pkgconf = configuration_data()
-pkgconf.set('prefix', atk_prefix)
-pkgconf.set('exec_prefix', atk_prefix)
-pkgconf.set('libdir', atk_libdir)
-pkgconf.set('includedir', atk_includedir)
-pkgconf.set('VERSION', meson.project_version())
-pkgconf.set('ATK_API_VERSION', atk_api_version)
-pkgconf.set('srcdir', '.')
-
-foreach pkg: [ 'atk.pc', ]
- configure_file(input: pkg + '.in',
- output: pkg,
- configuration: pkgconf,
- install: true,
- install_dir: join_paths(atk_libdir, 'pkgconfig'))
-endforeach
-
+pkgconfig = import('pkgconfig')
gnome = import('gnome')
# Internal configuration header