summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-01-04 16:37:41 -0700
committerEric Blake <eblake@redhat.com>2011-01-04 17:02:55 -0700
commitb4b41c0c80d714d40c519ad1d019446209d147f7 (patch)
tree2da075b33fa2bdefcd53f17608bf944f6ddfb510 /Makefile.am
parent1864b1a3c41a11a1c9dbb544db965042b4a8032c (diff)
downloadautoconf-b4b41c0c80d714d40c519ad1d019446209d147f7.tar.gz
doc: improve install.texi texinfo markup
This partially reverts commit 02fa53b19528cbb849b08b68074dcbc31c5a9715. * doc/install.texi: Don't force @firstparagraphindent on all clients; instead, add it only when building INSTALL. Compress copyright. * Makefile.am (INSTALL): Match gnulib's formatting. Reported by Karl Berry. Signed-off-by: Eric Blake <eblake@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b34d97ee..fcd5a169 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,8 +41,11 @@ pkgdata_DATA = $(srcdir)/INSTALL
MAINTAINERCLEANFILES = $(srcdir)/INSTALL
$(srcdir)/INSTALL: $(top_srcdir)/doc/install.texi
- $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) --plaintext -o $@ \
- $(top_srcdir)/doc/install.texi
+ echo @firstparagraphindent insert \
+ | cat - $(top_srcdir)/doc/install.texi > tmp.texi
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) \
+ --plaintext -o $@ tmp.texi
+ rm -f tmp.texi
endif