summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2013-05-04 11:50:10 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2013-05-04 11:50:10 +0200
commit2d3a2e36b595cd740894823d060e31c6c483f569 (patch)
treeba74fa042ecc41e025c2d37725b222b4db790e73 /Makefile.am
parente5e3a629e01c7642a46217817c32cfa86e9bd708 (diff)
parentf5f75eef28a32493258047eb3060478395a42120 (diff)
downloadautomake-2d3a2e36b595cd740894823d060e31c6c483f569.tar.gz
Merge branch 'branch-1.13.2' into maint
* branch-1.13.2: maint: targets and recipes to simplify testing on real-world packages build: preparatory refactoring build: tiny reduction in code duplication make flags analysis: handle more options with args make flags analysis: use simpler variable names make flags analysis: whitespace changes make flags analysis: embed in a subshell make flags analysis: be more robust make flags analysis: cater to GNU make 3.83 (still unreleased as of now) tests: expose weaknesses in make flags analysis tests: improve debugging output in checks on make flags analysis make flags analysis: refactor, to reduce code duplication tests: avoid one tricky use of "make -e" tests: avoid a spurious error with Solaris make subdirs: don't return false positives for the '-k' option's presence header-vars: recognize more make flags ('-k' in particular) header-vars: simplify how make flags are determined tests: remove dead code from t/make-dryrun.tap header-vars: new variable $(am__running_with_option) tests: expose bug#12554 (false positives for presence of '-k' make option)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 20 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e055612b..a98a1ce1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,6 +72,11 @@ EXTRA_DIST += \
HACKING \
PLANS
+# For some tests or targets, we need to have the just-build automake and
+# aclocal scripts avaiable on PATH.
+extend_PATH = \
+ { PATH='$(abs_builddir)/t/wrap'$(PATH_SEPARATOR)$$PATH && export PATH; }
+
# Make versioned links. We only run the transform on the root name;
# then we make a versioned link with the transformed base name. This
# seemed like the most reasonable approach.
@@ -601,8 +606,7 @@ EXTRA_DIST += doc/help2man
update_mans = \
$(AM_V_GEN): \
&& $(MKDIR_P) doc \
- && PATH="$(abs_builddir)/t/wrap$(PATH_SEPARATOR)$$PATH" \
- && export PATH \
+ && $(extend_PATH) \
&& $(PERL) $(srcdir)/doc/help2man --output=$@
doc/aclocal.1 doc/automake.1:
@@ -642,22 +646,25 @@ amhello_configury = \
dist_noinst_DATA += $(amhello_sources)
dist_doc_DATA = $(srcdir)/doc/amhello-1.0.tar.gz
+setup_autotools_paths = { \
+ $(extend_PATH) \
+ && ACLOCAL=aclocal-$(APIVERSION) && export ACLOCAL \
+ && AUTOMAKE=automake-$(APIVERSION) && export AUTOMAKE \
+ && AUTOCONF='$(am_AUTOCONF)' && export AUTOCONF \
+ && AUTOM4TE='$(am_AUTOM4TE)' && export AUTOM4TE \
+ && AUTORECONF='$(am_AUTORECONF)' && export AUTORECONF \
+ && AUTOHEADER='$(am_AUTOHEADER)' && export AUTOHEADER \
+ && AUTOUPDATE='$(am_AUTOUPDATE)' && export AUTOUPDATE \
+ && true; \
+}
+
# We depend on configure.ac so that we regenerate the tarball
# whenever the Automake version changes.
-# aclocal-$(APIVERSION) and automake-$(APIVERSION) are generated by
-# configure in 't/wrap'.
$(srcdir)/doc/amhello-1.0.tar.gz: $(amhello_sources) $(srcdir)/configure.ac
$(AM_V_GEN)tmp=amhello-output.tmp \
- && PATH="$(abs_top_builddir)/t/wrap$(PATH_SEPARATOR)$$PATH" \
- && export PATH \
&& $(am__cd) $(srcdir)/doc/amhello \
- && ACLOCAL=aclocal-$(APIVERSION) && export ACLOCAL \
- && AUTOMAKE=automake-$(APIVERSION) && export AUTOMAKE \
- && AUTOCONF='$(am_AUTOCONF)' && export AUTOCONF \
- && AUTOM4TE='$(am_AUTOM4TE)' && export AUTOM4TE \
- && AUTORECONF='$(am_AUTORECONF)' && export AUTORECONF \
- && AUTOHEADER='$(am_AUTOHEADER)' && export AUTOHEADER \
- && AUTOUPDATE='$(am_AUTOUPDATE)' && export AUTOUPDATE \
+ && : Make our aclocal and automake avaiable before system ones. \
+ && $(setup_autotools_paths) \
&& ( \
{ $(AM_V_P) || exec 5>&2 >$$tmp 2>&1; } \
&& $(am_AUTORECONF) -vfi \