summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-07-06 23:42:11 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-07-06 23:42:11 +0200
commit5197aba1d5e1895c28d66703b0b407c991f608fb (patch)
tree3798c0afed811366ec4474da85c55d6c89e3097f /Makefile.am
parent2d1f1043e900a746f57c34467d4de8b48e4efc8b (diff)
downloadautomake-5197aba1d5e1895c28d66703b0b407c991f608fb.tar.gz
cosmetics: rename t/ax/test-runner => t/ax/runtest
The latter is shorter and clearer. Better to do the rename early, before other developers or contributors begin to get used to the 'test-runner' name. * t/ax/test-runner.in: Rename ... * t/ax/runtest.in: ... like this. * Makefile.am, t/README, .gitignore: Adjust. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 7169eee01..9ef2f48c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -400,16 +400,16 @@ defs-static: defs-static.in Makefile
EXTRA_DIST += defs-static.in
CLEANFILES += defs-static
-t/ax/test-runner: t/ax/test-runner.in Makefile
+t/ax/runtest: t/ax/runtest.in Makefile
$(AM_V_at)rm -f $@ $@-t
- $(AM_V_GEN)in=t/ax/test-runner.in \
+ $(AM_V_GEN)in=t/ax/runtest.in \
&& $(MKDIR_P) t/ax \
- && $(do_subst) <$(srcdir)/t/ax/test-runner.in >$@-t \
+ && $(do_subst) <$(srcdir)/t/ax/runtest.in >$@-t \
&& chmod a+x $@-t
$(generated_file_finalize)
-EXTRA_DIST += t/ax/test-runner.in
-CLEANFILES += t/ax/test-runner
-noinst_SCRIPTS = t/ax/test-runner
+EXTRA_DIST += t/ax/runtest.in
+CLEANFILES += t/ax/runtest
+noinst_SCRIPTS = t/ax/runtest
# If two test scripts have the same basename, they will end up sharing
# the same log file, leading to all sort of undefined and undesired