summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2017-08-27 17:41:50 +0200
committerMathieu Lirzin <mthl@gnu.org>2017-08-29 17:18:18 +0200
commit64031f2aaf721043eff0aecec840bce71cec97ae (patch)
tree5fc85248ec1a43336ac54588a98792aed46b5093 /Makefile.am
parentbb64793a95ea0576c817a8e01f0a689d9547de4a (diff)
downloadautomake-64031f2aaf721043eff0aecec840bce71cec97ae.tar.gz
build: Add 'pre-inst-env' wrapper script
This script allows someone building Automake from source to easily run 'automake' and 'aclocal' without having to install it or knowing the existence of "wrapped" scripts in "bin" directory. * pre-inst-env.in: New script. * configure.ac: Generate 'pre-inst-env' at configure time. * Makefile.am (nodist_noinst_SCRIPTS, CLEANFILES): Add it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 65787e030..bdcafd933 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,6 +69,10 @@ generated_file_finalize = $(AM_V_at) \
fi; \
chmod a-w $@-t && mv -f $@-t $@
+# Wrapper for the build environment.
+nodist_noinst_SCRIPTS += pre-inst-env
+CLEANFILES += $(noinst_SCRIPTS)
+
# For some tests or targets, we need to have the just-build automake and
# aclocal scripts avaiable on PATH.
extend_PATH = \