summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-12-13 20:46:09 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-12-13 20:48:27 +0100
commit6432f117500714a6d3df5cab7c9b23275b46be5e (patch)
treea652391263ef3c35a2a956cc009564d781b3a969 /Makefile.am
parent319ae3dd47bddff0dbe4da2dca87f50d5347108c (diff)
downloadautomake-6432f117500714a6d3df5cab7c9b23275b46be5e.tar.gz
maint: adapt 'update-copyright' recipe to the new $(FETCHFILES) format
This is a fixup for commit v1.12.5-27-g71ce1b4 of 2012-12-09, "fetch: improve, and reduce code duplication". * Makefile.am (update-copyright): Adjust. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 22a8fbd14..89d747f7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1045,8 +1045,10 @@ update-copyright:
|| { echo "$@: cannot get current year" >&2; exit 1; }; \
sed -i "/^RELEASE_YEAR=/s/=.*$$/=$$current_year/" \
bootstrap.sh configure.ac; \
- excluded_re=`echo $(FETCHFILES) \
- | sed -e 's|^.*/|lib/|' -e 's| | lib/|g' -e 's, ,|,g'`; \
+ excluded_re=`\
+ for url in $(FETCHFILES); do echo "$$url"; done \
+ | sed -e 's!^.*/!!' -e 's!^.*=!!' -e 's!^!lib/!' \
+ | sed -e '$$!s,$$,|,' | tr -d '\012\015'`; \
$(GIT) ls-files \
| grep -Ev '^(lib/)?(COPYING|INSTALL)$$' \
| grep -Ev "^($$excluded_re)$$" \