summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-12-08 19:49:33 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-12-08 21:43:42 +0100
commit6e8997d86a0e6af3575f0f794380d4186fd446e4 (patch)
tree93557c15946636a8de93674ec839186ba91bbca0 /Makefile.am
parentc271b9c121c446fc35204e4d032aaff32f36ee6b (diff)
downloadautomake-6e8997d86a0e6af3575f0f794380d4186fd446e4.tar.gz
docs: copy the 'gendocs.sh' script from Texinfo CVS repository
As well as the 'gendocs_template' file. And enhance the "make fetch" target to keep them synced. It's better than having to fetch these files by hand each time a release is to be made. * Makefile.am (FETCHFILES): List 'gendocs.sh' and 'gendocs_template'. (fetch): Fetch them, into 'lib/'. (EXRA_DIST): Distribute them. * HACKING: Adjust instructions for generation of manuals. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 304fca55d..8c5fa7198 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -963,8 +963,10 @@ FETCHFILES = \
INSTALL \
config.guess \
config.sub \
-gnupload \
+gendocs.sh \
+gendocs_template \
gitlog-to-changelog \
+gnupload \
texinfo.tex \
update-copyright
@@ -977,6 +979,8 @@ fetch:
$(WGET_SV_GIT_CF)config.guess -O config.guess && \
$(WGET_SV_GIT_CF)config.sub -O config.sub && \
$(WGET_SV_CVS)texinfo/texinfo/doc/texinfo.tex -O texinfo.tex && \
+ $(WGET_SV_CVS)texinfo/texinfo/util/gendocs.sh -O gendocs.sh && \
+ $(WGET_SV_CVS)texinfo/texinfo/util/gendocs_template -O gendocs_template && \
$(WGET_SV_GIT_GL)doc/INSTALL -O INSTALL && \
$(WGET_SV_GIT_GL)build-aux/gnupload -O gnupload && \
$(WGET_SV_GIT_GL)build-aux/update-copyright -O update-copyright && \
@@ -997,6 +1001,7 @@ fetch:
exit $$stat
.PHONY: fetch
+EXTRA_DIST += lib/gendocs.sh lib/gendocs_template
## ------------------------------------------------ ##
## Update copyright years of all committed files. ##