summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-12-13 12:02:33 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-12-13 20:18:10 +0100
commitaf431631cc9db8b5426308d44fc2773afca5816c (patch)
tree5881629fac7b439f34861039184d3ea41b92f755 /Makefile.am
parent28d342cd1de27eec4659978e9af65154930b0f57 (diff)
downloadautomake-af431631cc9db8b5426308d44fc2773afca5816c.tar.gz
maint: rename rules to build/upload web manuals
The new names are the same used by the similar-purpose rules provided by the 'top/maint.mk' makefile in gnulib (as of commit v0.0-7741-g4a8c422). No need to have gratuitous incompatibilities. * Makefile.am (web-manuals): Rename ... (web-manual): ... like this. (upload-web-manuals): Rename ... (web-manual-update): ... like this. (clean-web-manuals): Rename ... (clean-web-manual): ... like this. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 7633c58f8..895afa8be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1003,7 +1003,7 @@ CVSU = cvsu
CVS_USER = $${USER}
WEBCVS_ROOT = cvs.savannah.gnu.org:/web
-web-manuals:
+web-manual:
$(AM_V_at)rm -rf doc/web-manuals
$(AM_V_GEN)tmp=$@.dir \
&& rm -rf $$tmp \
@@ -1024,9 +1024,9 @@ web-manuals:
&& mv -f $$tmp/manual/* doc/web-manuals \
&& rm -rf $$tmp \
&& { ! $(AM_V_P) || ls -l doc/web-manuals; }
-.PHONY: web-manuals
+.PHONY: web-manual
-upload-web-manuals:
+web-manual-update:
$(AM_V_at)fatal () { echo "$@: $$*" >&2; exit 1; }; \
$(determine_release_type); \
case $$release_type in \
@@ -1057,12 +1057,12 @@ upload-web-manuals:
&& $(CVS) ci -m $(VERSION) \
) \
&& rm -rf $$tmp
-.PHONY: upload-web-manuals
+.PHONY: web-manual-update
-clean-web-manuals:
+clean-web-manual:
$(AM_V_at)rm -rf doc/web-manuals
-.PHONY: clean-web-manuals
-clean-local: clean-web-manuals
+.PHONY: clean-web-manual
+clean-local: clean-web-manual
EXTRA_DIST += lib/gendocs.sh lib/gendocs_template