summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-12-14 15:43:27 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-12-14 15:43:27 +0100
commitb8c7e3f7ebf3ff8841b6bc1d224bbc87d71261ff (patch)
tree71aaad70b655e191e1029b9507a4efc21595015b /Makefile.am
parent2674291c3389fcde8c7206f858df12d66f123837 (diff)
parent454a1acda60854294ca6953621150707c037ee9a (diff)
downloadautomake-b8c7e3f7ebf3ff8841b6bc1d224bbc87d71261ff.tar.gz
Merge branch 'maint'
* maint: sync: update files from upstream with "make fetch" gitignore: align with recent changes fixup: add dummy rule for ChangeLog generation in Makefile.am maint: no longer use AM_MAKEFLAGS in maintainer rules maint: use more GNU make features in maintainer rules maint: move maintainer make rules in maint.mk
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am468
1 files changed, 6 insertions, 462 deletions
diff --git a/Makefile.am b/Makefile.am
index f3eb432d7..568652804 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,6 +69,7 @@ EXTRA_DIST += \
$(AUTOMAKESOURCES) \
bootstrap.sh \
GNUmakefile \
+ maint.mk \
syntax-checks.mk \
HACKING
@@ -115,6 +116,11 @@ INSTALL: lib/INSTALL
maintainer-clean-local:
rm -rf .autom4te.cache
+# So that automake won't complain about the missing ChangeLog.
+# The real rule for ChangeLog generation is now in maint.mk (as
+# it is maintainer-specific).
+ChangeLog:
+
## -------------------------------------------------------------------- ##
## Auxiliary scripts and files for use with "automake --add-missing". ##
@@ -661,465 +667,3 @@ EXTRA_DIST += \
old/ChangeLog.09 \
old/ChangeLog.11 \
old/TODO
-
-
-##########################################################################
-
-## Everything past here is useful to the maintainer, but probably not
-## to anybody else.
-
-##########################################################################
-
-
-## --------------------------------------------------------- ##
-## Automatic generation of the ChangeLog from git history. ##
-## --------------------------------------------------------- ##
-
-gitlog_to_changelog_command = $(PERL) $(srcdir)/lib/gitlog-to-changelog
-gitlog_to_changelog_fixes = $(srcdir)/.git-log-fix
-gitlog_to_changelog_options = --amend=$(gitlog_to_changelog_fixes) \
- --since='2011-12-28 00:00:00' \
- --no-cluster --format '%s%n%n%b'
-
-EXTRA_DIST += lib/gitlog-to-changelog
-EXTRA_DIST += $(gitlog_to_changelog_fixes)
-
-# When executed from a git checkout, generate the ChangeLog from the git
-# history. When executed from an extracted distribution tarball, just
-# copy the distributed ChangeLog in the build directory (and if this
-# fails, or if no distributed ChangeLog file is present, complain and
-# give an error).
-#
-# We need the apparently useless dependency from another .PHONY target
-# 'am--changelog-regen-hook' to work around a bug of Solaris make, which
-# doesn't execute the recipe of a target named as an existing file, even
-# if such target is declared '.PHONY' (yikes!)
-#
-.PHONY: am--changelog-regen-hook
-am--changelog-regen-hook:
-ChangeLog: am--changelog-regen-hook
- $(AM_V_GEN)set -e; set -u; \
-## The ChangeLog should be regenerated unconditionally when working from
-## checked-out sources; otherwise, if we're working from a distribution
-## tarball, we expect the ChangeLog to be distributed, so check that it
-## is indeed present in the source directory.
- if test -d $(srcdir)/.git; then \
- rm -f $@-t \
- && $(gitlog_to_changelog_command) \
- $(gitlog_to_changelog_options) >$@-t \
- && chmod a-w $@-t \
- && mv -f $@-t $@ \
- || exit 1; \
- elif test ! -f $(srcdir)/$@; then \
- echo "Source tree is not a git checkout, and no pre-existent" \
- "$@ file has been found there" >&2; \
- exit 1; \
- fi
-
-
-## --------------------------- ##
-## Perl coverage statistics. ##
-## --------------------------- ##
-
-PERL_COVERAGE_DB = $(abs_top_builddir)/cover_db
-PERL_COVERAGE_FLAGS = -MDevel::Cover=-db,$(PERL_COVERAGE_DB),-silent,on,-summary,off
-PERL_COVER = cover
-
-check-coverage-run recheck-coverage-run: all
- $(mkinstalldirs) $(PERL_COVERAGE_DB)
- PERL5OPT="$$PERL5OPT $(PERL_COVERAGE_FLAGS)"; export PERL5OPT; \
- WANT_NO_THREADS=yes; export WANT_NO_THREADS; unset AUTOMAKE_JOBS; \
- $(MAKE) $(AM_MAKEFLAGS) `echo $@ | sed 's/-coverage-run//'`
-
-check-coverage-report:
- @if test ! -d "$(PERL_COVERAGE_DB)"; then \
- echo "No coverage database found in '$(PERL_COVERAGE_DB)'." >&2; \
- echo "Please run \"make check-coverage\" first" >&2; \
- exit 1; \
- fi
- $(PERL_COVER) $(PERL_COVER_FLAGS) "$(PERL_COVERAGE_DB)"
-
-# We don't use direct dependencies here because we'd like to be able
-# to invoke the report even after interrupted check-coverage.
-check-coverage: check-coverage-run
- $(MAKE) $(AM_MAKEFLAGS) check-coverage-report
-
-recheck-coverage: recheck-coverage-run
- $(MAKE) $(AM_MAKEFLAGS) check-coverage-report
-
-clean-coverage:
- rm -rf "$(PERL_COVERAGE_DB)"
-clean-local: clean-coverage
-
-.PHONY: check-coverage recheck-coverage check-coverage-run \
- recheck-coverage-run check-coverage-report clean-coverage
-
-
-## ---------------------------------------------------- ##
-## Tagging and/or uploading stable and beta releases. ##
-## ---------------------------------------------------- ##
-
-GIT = git
-
-EXTRA_DIST += lib/gnupload
-
-base_version_rx = ^[1-9][0-9]*\.[0-9][0-9]*
-stable_major_version_rx = $(base_version_rx)$$
-stable_minor_version_rx = $(base_version_rx)\.[0-9][0-9]*$$
-beta_version_rx = $(base_version_rx)(\.[0-9][0-9]*)?[bdfhjlnprtvxz]$$
-match_version = echo "$(VERSION)" | $(EGREP) >/dev/null
-
-## Check that we don't have uncommitted or unstaged changes.
-## TODO: Maybe the git suite already offers a shortcut to verify if the
-## TODO: working directory is "clean" or not? If yes, use that instead
-## TODO: of duplicating the logic here.
-git_must_have_clean_workdir = \
- $(GIT) rev-parse --verify HEAD >/dev/null \
- && $(GIT) update-index -q --refresh \
- && $(GIT) diff-files --quiet \
- && $(GIT) diff-index --quiet --cached HEAD \
- || fatal "you have uncommitted or unstaged changes"
-
-determine_release_type = \
- if $(match_version) '$(stable_major_version_rx)'; then \
- release_type='Major release'; \
- announcement_type='major release'; \
- dest=ftp; \
- elif $(match_version) '$(stable_minor_version_rx)'; then \
- release_type='Minor release'; \
- announcement_type='maintenance release'; \
- dest=ftp; \
- elif $(match_version) '$(beta_version_rx)'; then \
- release_type='Beta release'; \
- announcement_type='test release'; \
- dest=alpha; \
- else \
- fatal "invalid version '$(VERSION)' for a release"; \
- fi
-
-# Help the debugging of $(determine_release_type) and related code.
-print-release-type:
- @set -e -u \
- && fatal () { echo "$@: $$*"; exit 0; } \
- && $(determine_release_type) \
- && echo "$$release_type $(VERSION);" \
- "it will be announced as a $$announcement_type"
-
-git-tag-release: maintainer-check
- @set -e; set -u; \
- fatal () { echo "$@: $$*; not tagging" >&2; exit 1; }; \
- case '$(AM_TAG_DRYRUN)' in \
- ""|[nN]|[nN]o|NO) run="";; \
- *) run="echo Running:";; \
- esac; \
- $(determine_release_type); \
- $(git_must_have_clean_workdir); \
-## If all was successful, tag the release in the local repository.
- $$run $(GIT) tag -s "v$(VERSION)" -m "$$release_type $(VERSION)"
-
-git-upload-release:
- @set -e; set -u; \
- fatal () { echo "$@: $$*; not releasing" >&2; exit 1; }; \
- $(determine_release_type); \
- dest=$$dest.gnu.org:automake; \
- $(git_must_have_clean_workdir); \
-## Check that we are releasing from a valid tag.
- tag=`$(GIT) describe` \
- && case $$tag in "v$(VERSION)") true;; *) false;; esac \
- || fatal "you can only create a release from a tagged version"; \
-## Build and upload the distribution tarball(s).
- $(MAKE) $(AM_MAKEFLAGS) dist || exit 1; \
- echo Will upload to $$dest: $(DIST_ARCHIVES); \
- $(srcdir)/lib/gnupload $(GNUPLOADFLAGS) --to $$dest $(DIST_ARCHIVES)
-
-.PHONY: print-release-type git-upload-release git-tag-release
-
-
-## ------------------------------------------------------------------ ##
-## Explore differences of autogenerated files in different commits. ##
-## ------------------------------------------------------------------ ##
-
-## Visually comparing differences between the Makefile.in files in
-## automake's own build system as generated in two different branches
-## might help to catch bugs and blunders. This has already happened a
-## few times in the past, when we used to version-control Makefile.in.
-autodiffs:
- @set -u; \
- NEW_COMMIT=$${NEW_COMMIT-"HEAD"}; \
- OLD_COMMIT=$${OLD_COMMIT-"HEAD~1"}; \
- am_gitdir='$(abs_top_srcdir)/.git'; \
- get_autofiles_from_rev () \
- { \
- rev=$$1 dir=$$2 \
- && echo "$@: will get files from revision $$rev" \
- && $(GIT) clone -q --depth 1 "$$am_gitdir" tmp \
- && $(am__cd) tmp \
- && $(GIT) checkout -q "$$rev" \
- && echo "$@: bootstrapping $$rev" \
- && $(SHELL) ./bootstrap.sh \
- && echo "$@: copying files from $$rev" \
- && makefile_ins=`find . -name Makefile.in` \
- && (tar cf - configure aclocal.m4 $$makefile_ins) | \
- (cd .. && $(am__cd) "$$dir" && tar xf -) \
- && cd .. \
- && rm -rf tmp; \
- }; \
- outdir=$@.dir \
-## Before proceeding, ensure the specified revisions truly exist.
- && $(GIT) --git-dir="$$am_gitdir" describe $$OLD_COMMIT >/dev/null \
- && $(GIT) --git-dir="$$am_gitdir" describe $$NEW_COMMIT >/dev/null \
- && rm -rf $$outdir \
- && mkdir $$outdir \
- && $(am__cd) $$outdir \
- && mkdir new old \
- && get_autofiles_from_rev $$OLD_COMMIT old \
- && get_autofiles_from_rev $$NEW_COMMIT new \
- && exit 0
-
-## With lots of eye candy; we like our developers pampered and spoiled :-)
-compare-autodiffs: autodiffs
- @set -u; \
- : $${COLORDIFF=colordiff} $${DIFF=diff}; \
- dir=autodiffs.dir; \
- if test ! -d "$$dir"; then \
- echo "$@: $$dir: Not a directory" >&2; \
- exit 1; \
- fi; \
- mydiff=false mypager=false; \
- if test -t 1; then \
- if ($$COLORDIFF -r . .) </dev/null >/dev/null 2>&1; then \
- mydiff=$$COLORDIFF; \
- mypager="less -R"; \
- else \
- mypager=less; \
- fi; \
- else \
- mypager=cat; \
- fi; \
- if test "$$mydiff" = false; then \
- if ($$DIFF -r -u . .); then \
- mydiff=$$DIFF; \
- else \
- echo "$@: no good-enough diff program specified" >&2; \
- exit 1; \
- fi; \
- fi; \
- st=0; $$mydiff -r -u $$dir/old $$dir/new | $$mypager || st=$$?; \
- rm -rf $$dir; \
- exit $$st
-.PHONY: autodiffs compare-autodiffs
-
-## ---------------------------------------------- ##
-## Help writing the announcement for a release. ##
-## ---------------------------------------------- ##
-
-PACKAGE_MAILINGLIST = automake@gnu.org
-
-announcement: NEWS
- $(AM_V_GEN): \
- && rm -f $@ $@-t \
- && fatal () { echo "$@: $$*" >&2; exit 1; } \
- && $(determine_release_type) \
- && ftp_base="ftp://$$dest.gnu.org/gnu/$(PACKAGE)" \
- && X () { printf '%s\n' "$$*" >> $@-t; } \
- && X "We are pleased to announce the $(PACKAGE_NAME) $(VERSION)" \
- "$$announcement_type." \
- && X \
- && X "**TODO** Brief description of the release here." \
- && X \
- && X "**TODO** This description can span multiple paragraphs." \
- && X \
- && X "See below for the detailed list of changes since the" \
- && X "previous version, as summarized by the NEWS file." \
- && X \
- && X "Download here:" \
- && X \
- && X " $$ftp_base/$(PACKAGE)-$(VERSION).tar.gz" \
- && X " $$ftp_base/$(PACKAGE)-$(VERSION).tar.xz" \
- && X \
- && X "Please report bugs and problems to" \
- "<$(PACKAGE_BUGREPORT)>," \
- && X "and send general comments and feedback to" \
- "<$(PACKAGE_MAILINGLIST)>." \
- && X \
- && X "Thanks to everyone who has reported problems, contributed" \
- && X "patches, and helped testing Automake!" \
- && X \
- && X "-*-*-*-" \
- && X \
- && sed -n -e '/^~~~/q' -e p $(srcdir)/NEWS >> $@-t \
- && mv -f $@-t $@
-.PHONY: announcement
-CLEANFILES += announcement
-
-## --------------------------------------------------------------------- ##
-## Synchronize third-party files that are committed in our repository. ##
-## --------------------------------------------------------------------- ##
-
-# Program to use to fetch files.
-WGET = wget
-
-# Some repositories we sync files from.
-SV_CVS = 'http://savannah.gnu.org/cgi-bin/viewcvs/~checkout~/'
-SV_GIT_CF = 'http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;hb=HEAD;f='
-SV_GIT_AC = 'http://git.savannah.gnu.org/gitweb/?p=autoconf.git;a=blob_plain;hb=HEAD;f='
-SV_GIT_GL = 'http://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=blob_plain;hb=HEAD;f='
-
-# Files that we fetch and which we compare against.
-# Note that the 'lib/COPYING' file must still be synced by hand.
-FETCHFILES = \
- $(SV_GIT_CF)config.guess \
- $(SV_GIT_CF)config.sub \
- $(SV_CVS)texinfo/texinfo/doc/texinfo.tex \
- $(SV_CVS)texinfo/texinfo/util/gendocs.sh \
- $(SV_CVS)texinfo/texinfo/util/gendocs_template \
- $(SV_GIT_GL)build-aux/gitlog-to-changelog \
- $(SV_GIT_GL)build-aux/gnupload \
- $(SV_GIT_GL)build-aux/update-copyright \
- $(SV_GIT_GL)doc/INSTALL
-
-# Fetch the latest versions of few scripts and files we care about.
-fetch:
- $(AM_V_at)rm -rf Fetchdir
- $(AM_V_at)mkdir Fetchdir
- $(AM_V_GEN)set -e; \
- if $(AM_V_P); then wget_opts=; else wget_opts=-nv; fi; \
- for url in $(FETCHFILES); do \
- file=`printf '%s\n' "$$url" | sed 's|^.*/||; s|^.*=||'`; \
-## A retrieval failure usually means a serious problem. Just bail out.
- $(WGET) $$wget_opts "$$url" -O Fetchdir/$$file || exit 1; \
- if cmp Fetchdir/$$file $(srcdir)/lib/$$file >/dev/null; then \
- : Nothing to do; \
- else \
- echo "$@: updating file $$file"; \
-## Ditto for a copying failure.
- cp Fetchdir/$$file $(srcdir)/lib/$$file || exit 1; \
- fi; \
- done
- $(AM_V_at)rm -rf Fetchdir
-.PHONY: fetch
-
-## ---------------------------------------------------------------------- ##
-## Generate and upload manuals in several formats, for the GNU website. ##
-## ---------------------------------------------------------------------- ##
-
-web_manual_dir = doc/web-manual
-
-RSYNC = rsync
-CVS = cvs
-CVSU = cvsu
-CVS_USER = $${USER}
-WEBCVS_ROOT = cvs.savannah.gnu.org:/web
-
-web-manual:
- $(AM_V_at)rm -rf $(web_manual_dir)
- $(AM_V_GEN)tmp=$@.dir \
- && rm -rf $$tmp \
- && mkdir $$tmp \
- && $(am__cd) $$tmp \
- && GENDOCS_TEMPLATE_DIR='$(abs_srcdir)/lib' \
- && export GENDOCS_TEMPLATE_DIR \
-## Needed to pacify extra checks from gendocs.sh.
- && $(LN_S) '$(abs_srcdir)/doc/$(PACKAGE).texi' . \
-## Try to respect silent rules.
- && if $(AM_V_P); then :; else exec >/dev/null 2>&1; fi \
-## Finally generate the manual in several formats.
- && $(SHELL) '$(abs_srcdir)/lib/gendocs.sh' \
- -I '$(abs_srcdir)/doc' --email $(PACKAGE_BUGREPORT) \
- $(PACKAGE) '$(PACKAGE_NAME)'
- $(AM_V_at)tmp=$@.dir \
- && mkdir $(web_manual_dir) \
- && mv -f $$tmp/manual/* $(web_manual_dir) \
- && rm -rf $$tmp \
- && { ! $(AM_V_P) || ls -l $(web_manual_dir); }
-.PHONY: web-manual
-
-web-manual-update:
- $(AM_V_at)fatal () { echo "$@: $$*" >&2; exit 1; }; \
- $(determine_release_type); \
- case $$release_type in \
- [Mm]ajor\ release|[Mm]inor\ release);; \
- *) echo "Cannot upload manuals from a \"$$release_type\"" >&2; \
- exit 1;; \
- esac
- $(AM_V_at)test -f $(web_manual_dir)/$(PACKAGE).html || { \
- echo 'You have to run "$(MAKE) web-manuals" before' \
- 'invoking "$(MAKE) $@"' >&2; \
- exit 1; \
- }
- $(AM_V_GEN): \
- && CVS_RSH=ssh && export CVS_RSH=ssh \
- && tmp=$@.dir \
- && rm -rf $$tmp \
- && mkdir $$tmp \
- && $(am__cd) $$tmp \
- && $(CVS) -z3 -d :ext:$(CVS_USER)@$(WEBCVS_ROOT)/$(PACKAGE) \
- co $(PACKAGE) \
- && cd .. \
-## According to the rsync manpage, "a trailing slash on the source [...]
-## avoids creating an additional directory level at the destination".
-## So the trailing '/' after '$(web_manual_dir)' below is intended.
- && $(RSYNC) -avP $(web_manual_dir)/ $$tmp/$(PACKAGE)/manual \
- && ( \
- cd $$tmp/$(PACKAGE)/manual \
- && new_files=`$(CVSU) --types='?'` \
- && new_files=`echo "$$new_files" | sed s/^..//` \
- && { test -z "$$new_files" || $(CVS) add -ko $$new_files; } \
- && $(CVS) ci -m $(VERSION) \
- ) \
- && rm -rf $$tmp
-.PHONY: web-manual-update
-
-clean-web-manual:
- $(AM_V_at)rm -rf $(web_manual_dir)
-.PHONY: clean-web-manual
-clean-local: clean-web-manual
-
-EXTRA_DIST += lib/gendocs.sh lib/gendocs_template
-
-## ------------------------------------------------ ##
-## Update copyright years of all committed files. ##
-## ------------------------------------------------ ##
-
-EXTRA_DIST += lib/update-copyright
-
-update_copyright_env = \
- UPDATE_COPYRIGHT_FORCE=1 \
- UPDATE_COPYRIGHT_USE_INTERVALS=2
-
-# In addition to the several README files, these as well are
-# not expected to have a copyright notice.
-files_without_copyright = \
- .autom4te.cfg \
- .git-log-fix \
- .gitattributes \
- .gitignore \
- INSTALL \
- COPYING \
- AUTHORS \
- THANKS \
- lib/INSTALL \
- lib/COPYING
-
-# This script is in the public domain.
-files_without_copyright += lib/mkinstalldirs
-
-# This script has an MIT-style license
-files_without_copyright += lib/install-sh
-
-.PHONY: update-copyright
-update-copyright:
- $(AM_V_GEN)set -e; \
- current_year=`date +%Y` && test -n "$$current_year" \
- || { echo "$@: cannot get current year" >&2; exit 1; }; \
- sed -i "/^RELEASE_YEAR=/s/=.*$$/=$$current_year/" \
- bootstrap.sh configure.ac; \
- excluded_re=`( \
- for url in $(FETCHFILES); do echo "$$url"; done \
- | sed -e 's!^.*/!!' -e 's!^.*=!!' -e 's!^!lib/!' \
- && for f in $(files_without_copyright); do echo $$f; done \
- ) | sed -e '$$!s,$$,|,' | tr -d '\012\015'`; \
- $(GIT) ls-files \
- | grep -Ev '(^|/)README$$' \
- | grep -Ev "^($$excluded_re)$$" \
- | $(update_copyright_env) xargs $(srcdir)/lib/$@