summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-07-02 17:24:24 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-07-02 19:04:50 +0200
commitd7d983b0276e903b492054d99cbbd6918279cb6a (patch)
treeb7e915ae02dff66c05b1c92c3d0e93cf5b82a2c7 /Makefile.am
parent22786e467794bb1ee0daf4f47b59de7db612204b (diff)
downloadautomake-d7d983b0276e903b492054d99cbbd6918279cb6a.tar.gz
tests: tests for stuff in contrib goes in 'contrib/t'
* t/help-multilib.sh: Move ... * contrib/t/help-multilib.sh: .. here. Remove a now-obsolete "FIXME" comment. * t/multlib.sh: Move ... * contrib/t/multilib.sh: .. here. Remove a now-obsolete "FIXME" comment. * t/parallel-test2.sh: Move ... * contrib/t/parallel-tests-html.sh: .. here. Remove a now-obsolete "FIXME" comment. * contrib/t/local.am: New, basically defining the list of tests for stuff in 'contrib/'. * t/list-of-tests.mk, Makefile.am: Adjust. * .gitignore: Update. * syntax-checks.mk (xtests): Likewise. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 860e7ac08..f05e82db5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -379,6 +379,11 @@ EXTRA_DIST += gen-testsuite-part
$(generated_TESTS): $(srcdir)/gen-testsuite-part
$(srcdir)/t/testsuite-part.am: $(srcdir)/gen-testsuite-part Makefile.am
+# Hand-written tests for stuff in 'contrib/'.
+include $(srcdir)/contrib/t/local.am
+TESTS += $(contrib_TESTS)
+EXTRA_DIST += $(contrib_TESTS)
+
# Static dependencies valid for each test case.
check_SCRIPTS = t/wrap/aclocal-$(APIVERSION) t/wrap/automake-$(APIVERSION)
dist_check_DATA = \