summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2013-01-03 12:54:07 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2013-01-03 12:57:00 +0100
commitda0dfbe7715c8f9558d7ee212b7eb8aac852a2ec (patch)
treea279a34e5354cc7ab2d58bfa38e0ac24cfd626da /Makefile.am
parent6d80cc2dba29a680cec596e233fab1e6185391b0 (diff)
downloadautomake-da0dfbe7715c8f9558d7ee212b7eb8aac852a2ec.tar.gz
tests: move runtest.in away from the top-lever directory
Not only this leaves the top-lever directory less cluttered, but helps in keeping the testsuite-related files more "centralized". * runtest.in: Move ... * t/ax/runtest.in: ... here. While at it, add customary '@configure_input@' comment line. * Makefile.am (runtest, EXTRA_DIST): Adjust. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c9d8b7a4..d868501f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -337,7 +337,7 @@ TESTS =
# Some testsuite-influential variables should be overridable from the
# test scripts, but not from the environment.
-# Keep this in sync with the similar list in 'runtest.in'.
+# Keep this in sync with the similar list in 't/ax/runtest.in'.
AM_TESTS_ENVIRONMENT = \
for v in \
required \
@@ -445,14 +445,14 @@ EXTRA_DIST += t/ax/shell-no-trail-bslash.in
CLEANFILES += t/ax/shell-no-trail-bslash
noinst_SCRIPTS += t/ax/shell-no-trail-bslash
-runtest: runtest.in Makefile
+runtest: t/ax/runtest.in Makefile
$(AM_V_at)rm -f $@ $@-t
- $(AM_V_GEN)in=runtest.in \
+ $(AM_V_GEN)in=t/ax/runtest.in \
&& $(MKDIR_P) t/ax \
- && $(do_subst) <$(srcdir)/runtest.in >$@-t \
+ && $(do_subst) <$(srcdir)/$$in >$@-t \
&& chmod a+x $@-t
$(generated_file_finalize)
-EXTRA_DIST += runtest.in
+EXTRA_DIST += t/ax/runtest.in
CLEANFILES += runtest
noinst_SCRIPTS += runtest