summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-07-26 18:16:47 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-07-26 18:16:47 +0200
commit106428fe4e73d5f9f5e7cc2e44a1e9b3b85606c1 (patch)
treeeafba44304c8d832d6107730d183eb1b6c4e400f /configure.ac
parent06143bdbbf8c3d358d51b646165634473c193afe (diff)
parent7d6b27434de032d8b6f852eb49e788b87a5e7695 (diff)
downloadautomake-106428fe4e73d5f9f5e7cc2e44a1e9b3b85606c1.tar.gz
Merge branch 'maint'
* maint: (38 commits) maintcheck: fixup list of files in $(xdefs) tests: never source test-defs.sh directly, source test-lib.sh instead runtest: sanitize test environment tests: remove an obsolescent self test tests: "am_using_tap=yes" -> "am_test_protocol=tap" tests: protect test libs against multiple inclusion configure: testsuite shell can return early from "dot-sourced" files tests: move sanitization and "Bournification" in the generic test lib tests: source test defs in the generic test lib test defs: no need to re-add $srcdir/t/ax to $PATH tests: split test libs into "generic" and "automake-specific" test setup: move actual calling of testsuite setup in ./defs test setup: merge definitions of function for simple tests test init: refactor: new function 'am_test_setup' test init: refactor: move displaying of debugging info later test init: refactor: new function 'am_setup_testdir' test init: refactor: new function 'am_set_exit_traps' configure: testsuite shell set exit traps in shell functions test init: refactor: new function 'am_exit_trap' test init: refactor: new function 'process_requirements' ... Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 69edd9a45..b3dfe1f79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -325,10 +325,23 @@ AC_DEFUN([_AM_CHECK_CANDIDATE_SHELL],
[], [am_score=1; break])
_AM_CHECK_SHELL_FEATURE([$1],
+ [can define exit traps in a shell function],
+ [fail=0 && foo() { trap 'fail=1' 0; } && foo && test $fail = 0],
+ [], [am_score=1; break])
+
+ _AM_CHECK_SHELL_FEATURE([$1],
[corrupts stderr with "set -x"],
[(set -x; P=1 true 2>&3) 3>&1 2>/dev/null | grep P=1],
[am_score=9], [])
+ echo 'return 34' > conftest-return.sh
+ echo 'ok=no' >> conftest-return.sh
+ _AM_CHECK_SHELL_FEATURE([$1],
+ [can return early from "dot-sourced" files],
+ [ok=yes; . ./conftest-return.sh; test $? -eq 34 && test $ok = yes],
+ [rm -f conftest-return.sh],
+ [rm -f conftest-return.sh; am_score=1; break])
+
echo 'alias false=echo' > conftest-alias.sh
echo 'false && test "$(false 97)" = 97' >> conftest-alias.sh
_AM_CHECK_SHELL_FEATURE([$1],