summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2017-08-29 11:27:52 +0200
committerMathieu Lirzin <mthl@gnu.org>2017-08-29 12:27:11 +0200
commitbb64793a95ea0576c817a8e01f0a689d9547de4a (patch)
tree51d47cffe798f1822e971fce095bacc4175c9029 /configure.ac
parent5521219348c55af354878583b99c5f9d66d6d38a (diff)
downloadautomake-bb64793a95ea0576c817a8e01f0a689d9547de4a.tar.gz
build: Move wrapped scripts in "bin" directory
Those scripts are used both in the build process and for the tests, so it seems clearer to not hide them in "t/wrap" directory. * t/wrap/aclocal.in: Rename to ... * bin/wrap-aclocal.in: ... this. * t/wrap/automake.in: Rename to ... * bin/wrap-automake.in: ... this. * configure.ac: Generate "bin/aclocal-${APIVERSION}" and "bin/automake-${APIVERSION}" at configure time. * t/Makefile.inc (nodist_noinst_SCRIPTS): Move wrapped scripts ... * bin/Makefile.inc (nodist_noinst_SCRIPTS): ... here. * Makefile.am (extend_PATH): Use "bin" directory. * t/ax/test-defs.in (am_bindir): Likewise. * t/get-sysconf.sh: Likewise. * .gitignore: Update.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 30ba7d97b..c9c257b37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,8 +67,8 @@ AC_SUBST([system_acdir], ["\${datadir}/aclocal"])
# aclocal and automake, hence the remake rules must use those versions
# as well. The extra quoting is to cater to cases when the build
# directory contains whitespace or shell metacharacters.
-ACLOCAL="\"`pwd`/t/wrap/aclocal-$APIVERSION\""
-AUTOMAKE="\"`pwd`/t/wrap/automake-$APIVERSION\""
+ACLOCAL="\"`pwd`/bin/aclocal-$APIVERSION\""
+AUTOMAKE="\"`pwd`/bin/automake-$APIVERSION\""
AC_PROG_LN_S
@@ -580,11 +580,11 @@ AC_SUBST([EXEEXT])
AC_CONFIG_FILES([Makefile])
AC_CONFIG_LINKS([GNUmakefile:GNUmakefile])
-AC_CONFIG_FILES([t/wrap/aclocal-${APIVERSION}:t/wrap/aclocal.in],
- [chmod +x t/wrap/aclocal-${APIVERSION}],
+AC_CONFIG_FILES([bin/aclocal-${APIVERSION}:bin/wrap-aclocal.in],
+ [chmod +x bin/aclocal-${APIVERSION}],
[APIVERSION=$APIVERSION])
-AC_CONFIG_FILES([t/wrap/automake-${APIVERSION}:t/wrap/automake.in],
- [chmod +x t/wrap/automake-${APIVERSION}],
+AC_CONFIG_FILES([bin/automake-${APIVERSION}:bin/wrap-automake.in],
+ [chmod +x bin/automake-${APIVERSION}],
[APIVERSION=$APIVERSION])
AC_OUTPUT