summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2013-01-01 01:20:49 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2013-01-01 01:20:49 +0100
commitf87ce5b01869361bb9f1035ae9f45bbf5e76b8bc (patch)
tree0789291516bd7ee983f4ce7bacc523ab9bcc48ef /configure.ac
parentf2443786a7dec55f498c06b8b207751aa06368cf (diff)
downloadautomake-f87ce5b01869361bb9f1035ae9f45bbf5e76b8bc.tar.gz
tests: don't always look for a C++ compiler named 'RCC'
On MacOS X (10.8), since the file system is case-insensitive, RCC can point to the "Resource Compiler" of the Qt4 Toolkit: <http://doc.qt.digia.com/4.2/rcc.html> That mismatch causes our configure script to erroneously think that no working C++ compiler is present, and that is thus necessary to skip all the test cases requiring such a compiler. So only look for a compiler named 'RCC' if the file system is case-sensible. Issue spotted analyzing the testsuite logs reported in bug#13317. * configure.ac: Adjust. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a62743ffb..6822639bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -470,12 +470,14 @@ AS_IF([test x"$GCC" = x"yes"], [am_CC_is_GNU=yes], [am_CC_is_GNU=no])
# On case-insensitive file systems (seen e.g. on Cygwin and Mac OS X)
# we must avoid looking for 'CC', because that would be the same as
# 'cc', and could cause $CXX to point to the C compiler, instead of
-# to a C++ compiler as expected. See automake bugs #11893 and #10766.
+# to a C++ compiler as expected (see automake bugs #11893 and #10766).
+# Similarly, we must avoid looking for 'RCC', as that can point to the
+# Qt4 "Resource Compiler": <http://doc.qt.digia.com/4.2/rcc.html>
if test -f /bIn/rMdIr || test -f /uSr/bIn/rMdIr; then
# Case-insensitive file system, don't look for CC.
- am_CC=
+ am_CC= am_RCC=
else
- am_CC=CC
+ am_CC=CC am_RCC=RCC
fi
# The list of C++ compilers here has been copied, pasted and edited
@@ -483,7 +485,7 @@ fi
# Keep it in sync, or better again, find out a way to avoid this code
# duplication.
_AM_COMPILER_CAN_FAIL([AC_PROG_CXX(dnl
- [aCC $am_CC FCC KCC RCC xlC_r xlC c++ cxx cc++ gpp g++])],
+ [aCC $am_CC FCC KCC $am_RCC xlC_r xlC c++ cxx cc++ gpp g++])],
[CXX=false; _AM_SKIP_COMP_TESTS([C++])])
AS_IF([test x"$GXX" = x"yes"], [am_CXX_is_GNU=yes], [am_CXX_is_GNU=no])