summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 20 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e055612b..a98a1ce1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,6 +72,11 @@ EXTRA_DIST += \
HACKING \
PLANS
+# For some tests or targets, we need to have the just-build automake and
+# aclocal scripts avaiable on PATH.
+extend_PATH = \
+ { PATH='$(abs_builddir)/t/wrap'$(PATH_SEPARATOR)$$PATH && export PATH; }
+
# Make versioned links. We only run the transform on the root name;
# then we make a versioned link with the transformed base name. This
# seemed like the most reasonable approach.
@@ -601,8 +606,7 @@ EXTRA_DIST += doc/help2man
update_mans = \
$(AM_V_GEN): \
&& $(MKDIR_P) doc \
- && PATH="$(abs_builddir)/t/wrap$(PATH_SEPARATOR)$$PATH" \
- && export PATH \
+ && $(extend_PATH) \
&& $(PERL) $(srcdir)/doc/help2man --output=$@
doc/aclocal.1 doc/automake.1:
@@ -642,22 +646,25 @@ amhello_configury = \
dist_noinst_DATA += $(amhello_sources)
dist_doc_DATA = $(srcdir)/doc/amhello-1.0.tar.gz
+setup_autotools_paths = { \
+ $(extend_PATH) \
+ && ACLOCAL=aclocal-$(APIVERSION) && export ACLOCAL \
+ && AUTOMAKE=automake-$(APIVERSION) && export AUTOMAKE \
+ && AUTOCONF='$(am_AUTOCONF)' && export AUTOCONF \
+ && AUTOM4TE='$(am_AUTOM4TE)' && export AUTOM4TE \
+ && AUTORECONF='$(am_AUTORECONF)' && export AUTORECONF \
+ && AUTOHEADER='$(am_AUTOHEADER)' && export AUTOHEADER \
+ && AUTOUPDATE='$(am_AUTOUPDATE)' && export AUTOUPDATE \
+ && true; \
+}
+
# We depend on configure.ac so that we regenerate the tarball
# whenever the Automake version changes.
-# aclocal-$(APIVERSION) and automake-$(APIVERSION) are generated by
-# configure in 't/wrap'.
$(srcdir)/doc/amhello-1.0.tar.gz: $(amhello_sources) $(srcdir)/configure.ac
$(AM_V_GEN)tmp=amhello-output.tmp \
- && PATH="$(abs_top_builddir)/t/wrap$(PATH_SEPARATOR)$$PATH" \
- && export PATH \
&& $(am__cd) $(srcdir)/doc/amhello \
- && ACLOCAL=aclocal-$(APIVERSION) && export ACLOCAL \
- && AUTOMAKE=automake-$(APIVERSION) && export AUTOMAKE \
- && AUTOCONF='$(am_AUTOCONF)' && export AUTOCONF \
- && AUTOM4TE='$(am_AUTOM4TE)' && export AUTOM4TE \
- && AUTORECONF='$(am_AUTORECONF)' && export AUTORECONF \
- && AUTOHEADER='$(am_AUTOHEADER)' && export AUTOHEADER \
- && AUTOUPDATE='$(am_AUTOUPDATE)' && export AUTOUPDATE \
+ && : Make our aclocal and automake avaiable before system ones. \
+ && $(setup_autotools_paths) \
&& ( \
{ $(AM_V_P) || exec 5>&2 >$$tmp 2>&1; } \
&& $(am_AUTORECONF) -vfi \