summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 22a8fbd14..89d747f7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1045,8 +1045,10 @@ update-copyright:
|| { echo "$@: cannot get current year" >&2; exit 1; }; \
sed -i "/^RELEASE_YEAR=/s/=.*$$/=$$current_year/" \
bootstrap.sh configure.ac; \
- excluded_re=`echo $(FETCHFILES) \
- | sed -e 's|^.*/|lib/|' -e 's| | lib/|g' -e 's, ,|,g'`; \
+ excluded_re=`\
+ for url in $(FETCHFILES); do echo "$$url"; done \
+ | sed -e 's!^.*/!!' -e 's!^.*=!!' -e 's!^!lib/!' \
+ | sed -e '$$!s,$$,|,' | tr -d '\012\015'`; \
$(GIT) ls-files \
| grep -Ev '^(lib/)?(COPYING|INSTALL)$$' \
| grep -Ev "^($$excluded_re)$$" \