summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index ab1dfedd8..7ac03df76 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,6 +73,11 @@ EXTRA_DIST += \
syntax-checks.mk \
HACKING
+# For some tests or targets, we need to have the just-build automake and
+# aclocal scripts avaiable on PATH.
+extend_PATH = \
+ { PATH='$(abs_builddir)/t/wrap'$(PATH_SEPARATOR)$$PATH && export PATH; }
+
# Make versioned links. We only run the transform on the root name;
# then we make a versioned link with the transformed base name. This
# seemed like the most reasonable approach.
@@ -574,8 +579,7 @@ EXTRA_DIST += doc/help2man
update_mans = \
$(AM_V_GEN): \
&& $(MKDIR_P) doc \
- && PATH="$(abs_builddir)/t/wrap$(PATH_SEPARATOR)$$PATH" \
- && export PATH \
+ && $(extend_PATH) \
&& $(PERL) $(srcdir)/doc/help2man --output=$@
doc/aclocal.1 doc/automake.1:
@@ -617,13 +621,11 @@ dist_doc_DATA = $(srcdir)/doc/amhello-1.0.tar.gz
# We depend on configure.ac so that we regenerate the tarball
# whenever the Automake version changes.
-# aclocal-$(APIVERSION) and automake-$(APIVERSION) are generated by
-# configure in 't/wrap'.
$(srcdir)/doc/amhello-1.0.tar.gz: $(amhello_sources) $(srcdir)/configure.ac
$(AM_V_GEN)tmp=amhello-output.tmp \
- && PATH="$(abs_top_builddir)/t/wrap$(PATH_SEPARATOR)$$PATH" \
- && export PATH \
&& $(am__cd) $(srcdir)/doc/amhello \
+ && : Make our aclocal and automake avaiable before system ones; \
+ && $(extend_PATH) \
&& ACLOCAL=aclocal-$(APIVERSION) && export ACLOCAL \
&& AUTOMAKE=automake-$(APIVERSION) && export AUTOMAKE \
&& AUTOCONF='$(am_AUTOCONF)' && export AUTOCONF \