summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKevron Rees <tripzero.kev@gmail.com>2016-08-04 21:40:34 -0700
committerGitHub <noreply@github.com>2016-08-04 21:40:34 -0700
commitf1146db924e8633f1285689a6d5491f86f13e0d7 (patch)
tree28fa91078914313e9085d43c8c68aaf5d3a7956c /CMakeLists.txt
parentb566536fe969c1290299427765402c6ccea3a2b1 (diff)
parent3c152fe0acff9c0f6056246bb6e0301e6c582092 (diff)
downloadautomotive-message-broker-f1146db924e8633f1285689a6d5491f86f13e0d7.tar.gz
Merge pull request #69 from fredcadete/master
cmake: assorted install path fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f435b0cd..230f3c92 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,10 +24,10 @@ add_definitions(-DPROJECT_SERIES="${PROJECT_SERIES}")
set (LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)" )
set (LIB_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}" )
-set (PLUGIN_INSTALL_PATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/${PROJECT_NAME}")
+set (PLUGIN_INSTALL_PATH "${CMAKE_INSTALL_LIBDIR}/${PROJECT_NAME}")
set (INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_INCLUDEDIR}")
set (DOC_INSTALL_DIR "${CMAKE_INSTALL_DOCDIR}/${PROJECT_SERIES}")
-set (PLUGIN_SEGMENT_INSTALL_PATH "/${CMAKE_INSTALL_SYSCONFDIR}/ambd/plugins.d")
+set (PLUGIN_SEGMENT_INSTALL_PATH "${CMAKE_INSTALL_SYSCONFDIR}/ambd/plugins.d")
option(qtmainloop "Use QCoreApplication mainloop " OFF)
option(websocket_plugin "websocket source and sink plugins" OFF)