summaryrefslogtreecommitdiff
path: root/ambd/CMakeLists.txt
diff options
context:
space:
mode:
authorKevron Rees <tripzero.kev@gmail.com>2015-04-06 08:33:33 -0700
committerKevron Rees <tripzero.kev@gmail.com>2015-04-06 08:33:33 -0700
commit4279804ec1986e918af017c8110dd5caf64e4887 (patch)
treec6897aa13d102f53e380c07aa096658b0452530d /ambd/CMakeLists.txt
parent9e370e5052ec254aa80306f6741dbc12bfb6bd5c (diff)
parent947be368482abf6f5d38a79213d9ba9d1c5debd4 (diff)
downloadautomotive-message-broker-4279804ec1986e918af017c8110dd5caf64e4887.tar.gz
Merge pull request #48 from CogentEmbedded/master
Fixes and improvements in CAN support
Diffstat (limited to 'ambd/CMakeLists.txt')
-rw-r--r--ambd/CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/ambd/CMakeLists.txt b/ambd/CMakeLists.txt
index 4c66e05e..c17222a0 100644
--- a/ambd/CMakeLists.txt
+++ b/ambd/CMakeLists.txt
@@ -36,7 +36,12 @@ add_executable(ambd ${ambd_sources})
include_directories(${include_dirs} )
target_link_libraries(ambd ${link_libraries} dl amb ${gio_LIBRARIES})
-configure_file (${CMAKE_CURRENT_SOURCE_DIR}/config.in.json ${CMAKE_CURRENT_BINARY_DIR}/config @ONLY)
-
-install (TARGETS ambd RUNTIME DESTINATION bin)
-install (FILES ${CMAKE_CURRENT_BINARY_DIR}/config DESTINATION /etc/ambd)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.in.json ${CMAKE_CURRENT_BINARY_DIR}/config @ONLY)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/ambd.in ${CMAKE_CURRENT_BINARY_DIR}/init.d/ambd @ONLY)
+
+install(TARGETS ambd RUNTIME DESTINATION bin)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/config DESTINATION /etc/ambd)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/init.d/ambd
+ DESTINATION /etc/init.d/
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+)