summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGabriel F. T. Gomes <gabriel@inconstante.net.br>2019-08-07 09:17:13 -0300
committerGabriel F. T. Gomes <gabriel@inconstante.net.br>2019-08-07 09:17:13 -0300
commit5732da2af736c40cf693354485446ab4867ecb4d (patch)
tree76d76cdfa16ca62d20fb109da13895ec64fff110 /Makefile.am
parent9cd22d1df8f0f5b554858471c86faa9f37b8fed4 (diff)
downloadbash-completion-5732da2af736c40cf693354485446ab4867ecb4d.tar.gz
New upstream version 2.9upstream/2.9
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 15 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 1df73ae0..8f441185 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,22 +15,25 @@ cmakeconfigdir = $(datadir)/cmake/$(PACKAGE)/
cmakeconfig_DATA = bash-completion-config.cmake \
bash-completion-config-version.cmake
-bash_completion.sh: bash_completion.sh.in Makefile
- sed -e 's|@pkgdatadir[@]|$(pkgdatadir)|' <$(srcdir)/$@.in >$@
+%: %.in Makefile
+ $(SED) \
+ -e 's|@prefix[@]|$(prefix)|' \
+ -e 's|@compatdir[@]|$(compatdir)|' \
+ -e 's|@pkgdatadir[@]|$(pkgdatadir)|' \
+ -e 's|@VERSION[@]|$(VERSION)|' \
+ <$(srcdir)/$@.in >$@
-CLEANFILES = bash_completion.sh bash-completion.pc
+CLEANFILES = bash_completion.sh bash-completion.pc \
+ bash-completion-config.cmake bash-completion-config-version.cmake
EXTRA_DIST = CHANGES $(pkgdata_DATA) bash_completion.sh.in .dir-locals.el \
- .editorconfig README.md CONTRIBUTING.md
+ .editorconfig README.md CONTRIBUTING.md pyproject.toml .perltidyrc \
+ .shellcheckrc bash-completion.pc.in bash-completion-config.cmake.in \
+ bash-completion-config-version.cmake.in
install-data-hook:
tmpfile=`mktemp $${TMPDIR:-/tmp}/bash_completion.XXXXXX` && \
- sed -e 's|-/etc/bash_completion\.d|-$(compatdir)|' \
- $(DESTDIR)$(pkgdatadir)/bash_completion > $$tmpfile && \
- cat $$tmpfile > $(DESTDIR)$(pkgdatadir)/bash_completion && \
- sed -e 's|\$${prefix}|$(prefix)|' \
- $(DESTDIR)$(datadir)/cmake/$(PACKAGE)/bash-completion-config.cmake \
- > $$tmpfile && \
- cat $$tmpfile > \
- $(DESTDIR)$(datadir)/cmake/$(PACKAGE)/bash-completion-config.cmake && \
+ $(SED) -e 's|-/etc/bash_completion\.d|-$(compatdir)|' \
+ $(DESTDIR)$(pkgdatadir)/bash_completion >$$tmpfile && \
+ cat $$tmpfile >$(DESTDIR)$(pkgdatadir)/bash_completion && \
rm $$tmpfile