summaryrefslogtreecommitdiff
path: root/completions/Makefile.am
diff options
context:
space:
mode:
authorGabriel F. T. Gomes <gabriel@inconstante.eti.br>2017-09-25 23:46:54 -0300
committerGabriel F. T. Gomes <gabriel@inconstante.eti.br>2017-09-25 23:46:54 -0300
commit6d88f1055806932d9291f96847d2b691cccda2cd (patch)
tree0ff79eedaa8a239331256048981deedbd0721965 /completions/Makefile.am
parent059a87a5936cfebfd2d71ab8057002cafb2ea051 (diff)
downloadbash-completion-6d88f1055806932d9291f96847d2b691cccda2cd.tar.gz
New upstream version 2.7upstream/2.7
Diffstat (limited to 'completions/Makefile.am')
-rw-r--r--completions/Makefile.am153
1 files changed, 127 insertions, 26 deletions
diff --git a/completions/Makefile.am b/completions/Makefile.am
index f312b3a9..f04d7c36 100644
--- a/completions/Makefile.am
+++ b/completions/Makefile.am
@@ -1,12 +1,16 @@
bashcompdir = $(pkgdatadir)/completions
-bashcomp_DATA = a2x \
+bashcomp_DATA = 2to3 \
+ 7z \
+ a2x \
abook \
aclocal \
acpi \
+ adb \
add_members \
alias \
ant \
apache2ctl \
+ appdata-validate \
apt-build \
apt-cache \
apt-get \
@@ -23,11 +27,13 @@ bashcomp_DATA = a2x \
autoscan \
avctrl \
badblocks \
+ bind \
bk \
brctl \
btdownloadheadless.py \
+ bts \
bzip2 \
- cal \
+ _cal \
cancel \
cardctl \
ccache \
@@ -37,13 +43,15 @@ bashcomp_DATA = a2x \
change_pw \
check_db \
check_perms \
+ checksec \
+ _chfn \
chgrp \
chkconfig \
chown \
chpasswd \
chronyc \
chrpath \
- chsh \
+ _chsh \
cksfv \
cleanarch \
clisp \
@@ -62,10 +70,11 @@ bashcomp_DATA = a2x \
cvs \
cvsps \
dd \
+ deja-dup \
desktop-file-validate \
dhclient \
dict \
- dmesg \
+ _dmesg \
dnsspoof \
dot \
dpkg \
@@ -76,7 +85,7 @@ bashcomp_DATA = a2x \
dumpe2fs \
e2freefrag \
e2label \
- eject \
+ _eject \
eog \
ether-wake \
evince \
@@ -92,6 +101,8 @@ bashcomp_DATA = a2x \
filesnarf \
find \
find_member \
+ flake8 \
+ freebsd-update \
freeciv-gtk2 \
freeciv-server \
function \
@@ -104,7 +115,9 @@ bashcomp_DATA = a2x \
genisoimage \
getent \
gkrellm \
+ gm \
gnatmake \
+ gnokii \
gnome-mplayer \
gpasswd \
gpg \
@@ -120,12 +133,13 @@ bashcomp_DATA = a2x \
gzip \
hcitool \
hddtemp \
- hexdump \
+ _hexdump \
hid2hci \
+ hostname \
hping2 \
htop \
htpasswd \
- hwclock \
+ _hwclock \
iconv \
id \
idn \
@@ -137,7 +151,7 @@ bashcomp_DATA = a2x \
installpkg \
interdiff \
invoke-rc.d \
- ionice \
+ _ionice \
ip \
iperf \
ipmitool \
@@ -154,7 +168,9 @@ bashcomp_DATA = a2x \
jarsigner \
java \
javaws \
+ jpegoptim \
jps \
+ jshint \
k3b \
kcov \
kill \
@@ -177,7 +193,7 @@ bashcomp_DATA = a2x \
list_lists \
list_members \
list_owners \
- look \
+ _look \
lpq \
lpr \
lrzip \
@@ -187,6 +203,7 @@ bashcomp_DATA = a2x \
luseradd \
luserdel \
lvm \
+ lz4 \
lzip \
lzma \
lzop \
@@ -206,12 +223,15 @@ bashcomp_DATA = a2x \
mkinitrd \
mktemp \
mmsitepass \
+ _mock \
modinfo \
modprobe \
+ _modules \
monodevelop \
mount \
mount.linux \
mplayer \
+ mr \
msynctool \
mtx \
munindoc \
@@ -225,20 +245,22 @@ bashcomp_DATA = a2x \
nc \
ncftp \
nethogs \
- newgrp \
+ _newgrp \
newlist \
newusers \
ngrep \
nmap \
- nmcli \
+ _nmcli \
nslookup \
ntpdate \
openssl \
opera \
+ optipng \
p4 \
pack200 \
passwd \
patch \
+ pdftotext \
perl \
pgrep \
pidof \
@@ -255,7 +277,9 @@ bashcomp_DATA = a2x \
pm-hibernate \
pm-is-supported \
pm-powersave \
+ pngfix \
portinstall \
+ portsnap \
portupgrade \
postcat \
postconf \
@@ -271,9 +295,12 @@ bashcomp_DATA = a2x \
pwd \
pwdx \
pwgen \
+ py.test \
pydoc \
+ pyflakes \
pylint \
python \
+ pyvenv \
qdbus \
qemu \
qrunner \
@@ -283,9 +310,10 @@ bashcomp_DATA = a2x \
rdesktop \
remove_members \
removepkg \
- renice \
+ _renice \
+ _repomanage \
reportbug \
- reptyr \
+ _reptyr \
resolvconf \
rfkill \
ri \
@@ -298,7 +326,8 @@ bashcomp_DATA = a2x \
rpmcheck \
rrdtool \
rsync \
- rtcwake \
+ _rtcwake \
+ _runuser \
sbcl \
sbopkg \
screen \
@@ -315,25 +344,33 @@ bashcomp_DATA = a2x \
ssh \
ssh-add \
ssh-copy-id \
+ ssh-keygen \
sshfs \
sshmitm \
sshow \
strace \
strings \
- su \
+ _su \
sudo \
svcadm \
svk \
+ _svn \
+ _svnadmin \
+ _svnlook \
sync_members \
+ synclient \
sysbench \
sysctl \
tar \
tcpdump \
tcpkill \
tcpnice \
+ timeout \
+ tipc \
tracepath \
tshark \
tune2fs \
+ _udevadm \
umount \
umount.linux \
unace \
@@ -359,6 +396,7 @@ bashcomp_DATA = a2x \
withlist \
wodim \
wol \
+ _write \
wsimport \
wtf \
wvdial \
@@ -377,13 +415,21 @@ bashcomp_DATA = a2x \
xz \
xzdec \
ypmatch \
- yum-arch
+ _yum \
+ yum-arch \
+ zopfli \
+ zopflipng
-EXTRA_DIST = $(bashcomp_DATA) \
- _mock _modules _subversion _udevadm _yum _yum-utils
+EXTRA_DIST = $(bashcomp_DATA)
CLEANFILES = \
+ 7za \
+ aclocal-1.10 \
aclocal-1.11 \
+ aclocal-1.12 \
+ aclocal-1.13 \
+ aclocal-1.14 \
+ aclocal-1.15 \
alpine \
alternatives \
animate \
@@ -391,9 +437,15 @@ CLEANFILES = \
arm-koji \
asciidoc.py \
autoheader \
+ automake-1.10 \
automake-1.11 \
+ automake-1.12 \
+ automake-1.13 \
+ automake-1.14 \
+ automake-1.15 \
autossh \
autoupdate \
+ bsdtar \
btdownloadcurses.py \
btdownloadgui.py \
c++ \
@@ -412,6 +464,7 @@ CLEANFILES = \
conjure \
cowthink \
createdb \
+ createuser \
dcop \
declare \
dfutool \
@@ -420,14 +473,19 @@ CLEANFILES = \
dpkg-query \
dpkg-reconfigure \
dropdb \
+ dropuser \
edquota \
+ f77 \
+ f95 \
filebucket \
freeciv-sdl \
freeciv-xaw \
g++ \
g4 \
g77 \
+ g95 \
gcj \
+ gfortran \
gkrellm2 \
gmake \
gmplayer \
@@ -469,9 +527,11 @@ CLEANFILES = \
lvresize \
lvs \
lvscan \
+ lz4c \
mailsnarf \
mdecrypt \
mencoder \
+ micropython \
mkisofs \
mogrify \
montage \
@@ -510,9 +570,18 @@ CLEANFILES = \
pvs \
pvscan \
pxz \
+ py.test-2 \
+ py.test-3 \
pydoc3 \
+ pypy \
+ pypy3 \
python2 \
python3 \
+ pyvenv-3.4 \
+ pyvenv-3.5 \
+ qemu-kvm \
+ qemu-system-i386 \
+ qemu-system-x86_64 \
quotacheck \
quotaoff \
quotaon \
@@ -532,6 +601,7 @@ CLEANFILES = \
sdptool \
setquota \
sftp \
+ sidedoor \
slogin \
smbcacls \
smbcquotas \
@@ -541,6 +611,7 @@ CLEANFILES = \
smbtree \
sparc-koji \
spovray \
+ star \
stream \
sudoedit \
tightvncviewer \
@@ -571,7 +642,12 @@ CLEANFILES = \
ypcat
symlinks: $(targetdir) $(DATA)
- for file in aclocal-1.11 ; do \
+ for file in 7za ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) 7z $(targetdir)/$$file ; \
+ done
+ for file in aclocal-1.10 aclocal-1.11 aclocal-1.12 aclocal-1.13 \
+ aclocal-1.14 aclocal-1.15 ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) aclocal $(targetdir)/$$file ; \
done
@@ -583,7 +659,8 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) asciidoc $(targetdir)/$$file ; \
done
- for file in automake-1.11 ; do \
+ for file in automake-1.10 automake-1.11 automake-1.12 automake-1.13 \
+ automake-1.14 automake-1.15 ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) automake $(targetdir)/$$file ; \
done
@@ -605,7 +682,7 @@ symlinks: $(targetdir) $(DATA)
done
for file in ncal ; do \
rm -f $(targetdir)/$$file && \
- $(LN_S) cal $(targetdir)/$$file ; \
+ $(LN_S) _cal $(targetdir)/$$file ; \
done
for file in pccardctl ; do \
rm -f $(targetdir)/$$file && \
@@ -648,7 +725,7 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) function $(targetdir)/$$file ; \
done
- for file in g++ c++ g77 gcj gpc cc ; do \
+ for file in cc c++ g++ gfortran f77 g77 f95 g95 gcj gpc ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) gcc $(targetdir)/$$file ; \
done
@@ -671,7 +748,7 @@ symlinks: $(targetdir) $(DATA)
done
for file in hd ; do \
rm -f $(targetdir)/$$file && \
- $(LN_S) hexdump $(targetdir)/$$file ; \
+ $(LN_S) _hexdump $(targetdir)/$$file ; \
done
for file in hping hping3 ; do \
rm -f $(targetdir)/$$file && \
@@ -719,6 +796,10 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) lvm $(targetdir)/$$file ; \
done
+ for file in lz4c ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) lz4 $(targetdir)/$$file ; \
+ done
for file in clzip pdlzip plzip ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) lzip $(targetdir)/$$file ; \
@@ -775,7 +856,7 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) pm-hibernate $(targetdir)/$$file ; \
done
- for file in createdb dropdb ; do \
+ for file in createdb createuser dropdb dropuser ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) psql $(targetdir)/$$file ; \
done
@@ -792,18 +873,30 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) puppet $(targetdir)/$$file ; \
done
+ for file in py.test-2 py.test-3 ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) py.test $(targetdir)/$$file ; \
+ done
for file in pydoc3 ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) pydoc $(targetdir)/$$file ; \
done
- for file in python2 python3 ; do \
+ for file in pypy pypy3 python2 python3 micropython ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) python $(targetdir)/$$file ; \
done
+ for file in pyvenv-3.4 pyvenv-3.5 ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) pyvenv $(targetdir)/$$file ; \
+ done
for file in dcop ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) qdbus $(targetdir)/$$file ; \
done
+ for file in qemu-kvm qemu-system-i386 qemu-system-x86_64 ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) qemu $(targetdir)/$$file ; \
+ done
for file in setquota edquota quotacheck repquota quotaon quotaoff ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) quota $(targetdir)/$$file ; \
@@ -828,7 +921,7 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) sbcl $(targetdir)/$$file ; \
done
- for file in slogin autossh sftp scp ; do \
+ for file in slogin autossh sftp scp sidedoor ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) ssh $(targetdir)/$$file ; \
done
@@ -871,3 +964,11 @@ all-local: symlinks
install-data-local: targetdir = $(DESTDIR)$(bashcompdir)
install-data-local: symlinks
+
+check-local:
+ ret=0
+ for file in $(bashcomp_DATA) ; do \
+ $${bashcomp_bash:-$${BASH:-bash}} \
+ -O extglob -n $$file || ret=$$? ; \
+ done ; \
+ exit $$ret