summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGabriel F. T. Gomes <gabriel@inconstante.eti.br>2018-11-02 18:00:59 -0300
committerGabriel F. T. Gomes <gabriel@inconstante.eti.br>2018-11-02 18:00:59 -0300
commit7f8a7f05ec56055bc14f7d179b4022f7ddd3d586 (patch)
treef5bb62d578e7663afc45b6beb5ffdb4feb1f5e6d /debian
parent32b4dc89e47bd20920ea84929d445d0f0812706c (diff)
downloadbash-completion-7f8a7f05ec56055bc14f7d179b4022f7ddd3d586.tar.gz
Fix completion for cvs log command
Tim Connors reported the bug in Debian [1] and the fix has been implemented upstream [2]. However, a new version of bash-completion has not yet been released, so Debian carries the fix. Thanks to Tim Connors for reporting. [1] https://bugs.debian.org/892080 [2] https://github.com/scop/bash-completion/commits/b0851c06d050
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/08-completion-for-cvs-log.patch26
-rw-r--r--debian/patches/series1
3 files changed, 28 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index dd49c326..fc069a69 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
bash-completion (1:2.8-2) UNRELEASED; urgency=low
* Fix for held packages completion in dpkg (Closes: #907294)
+ * Fix for cvs log completion (Closes: #892080)
-- Gabriel F. T. Gomes <gabriel@inconstante.eti.br> Fri, 02 Nov 2018 13:28:00 -0300
diff --git a/debian/patches/08-completion-for-cvs-log.patch b/debian/patches/08-completion-for-cvs-log.patch
new file mode 100644
index 00000000..a28c47cb
--- /dev/null
+++ b/debian/patches/08-completion-for-cvs-log.patch
@@ -0,0 +1,26 @@
+From: Gabriel F. T. Gomes <gabriel@inconstante.eti.br>
+Subject: Add completion for the cvs log command
+Origin: vendor, https://bugs.debian.org/892080
+Bug-Debian: https://bugs.debian.org/892080
+Forwarded: yes, https://github.com/scop/bash-completion/pull/194
+
+The 'cvs log' command takes two types of arguments: options and files.
+As reported by a Debian user [1], completion with filenames is not
+working. As a matter of fact, nor are completions with options. This
+patch adds completions for filenames and options to 'cvs log'.
+
+[1] https://bugs.debian.org/892080
+
+diff --git a/completions/cvs b/completions/cvs
+index fee256f2..357841ad 100644
+--- a/completions/cvs
++++ b/completions/cvs
+@@ -264,7 +264,7 @@ _cvs()
+ cvsroot)
+ _cvs_roots
+ ;;
+- diff)
++ diff|log)
+ if [[ "$cur" == -* ]]; then
+ _cvs_command_options "$1" $mode
+ [[ $COMPREPLY == *= ]] && compopt -o nospace
diff --git a/debian/patches/series b/debian/patches/series
index 09d794ad..cc09e7f1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -6,4 +6,5 @@
05-list-held-packages-in-dpkg.patch
06-xpdf_support_compressed_pdf.patch
07-dpkg_support_raw-extract_vextract.patch
+08-completion-for-cvs-log.patch
99-use-install-data-hook.patch