summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChet Ramey <chet.ramey@case.edu>2021-07-06 15:35:08 -0400
committerChet Ramey <chet.ramey@case.edu>2021-07-06 15:35:08 -0400
commit5a0e5b7b2862394cefccb919cddabf24f0ab4730 (patch)
tree82c2a11a2f481031d273fb59e5d76d216313fcc4 /configure.ac
parent3fb16fce322266681faef39c11e3069437caadd9 (diff)
downloadbash-5a0e5b7b2862394cefccb919cddabf24f0ab4730.tar.gz
optimization changes; makefile changes to make specifying CFLAGS less annoying; print completions reusably
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 12 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index e47aed24..7bfc3fef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,7 @@ dnl Process this file with autoconf to produce a configure script.
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-AC_REVISION([for Bash 5.1, version 5.023])dnl
+AC_REVISION([for Bash 5.1, version 5.025])dnl
define(bashvers, 5.1)
define(relstatus, maint)
@@ -414,9 +414,9 @@ dnl different environment
AC_PROG_CC
if test -n "$want_auto_cflags"; then
- AUTO_CFLAGS="-g ${GCC+-O2}"
- AUTO_LDFLAGS="-g ${GCC+-O2}"
- STYLE_CFLAGS="${GCC+-Wno-parentheses} ${GCC+-Wno-format-security}"
+ AUTO_CFLAGS="-g ${GCC:+-O2}"
+ AUTO_LDFLAGS="-g ${GCC:+-O2}"
+ STYLE_CFLAGS="${GCC:+-Wno-parentheses} ${GCC:+-Wno-format-security}"
else
AUTO_CFLAGS= AUTO_LDFLAGS= STYLE_CFLAGS=
fi
@@ -516,9 +516,12 @@ if test "X$cross_compiling" = "Xno"; then
fi
# CFLAGS set above to default value if not passed in environment
if test -n "$want_auto_cflags" ; then
- CFLAGS_FOR_BUILD="${CFLAGS} ${STYLE_CFLAGS}"
+ CFLAGS_FOR_BUILD="${CFLAGS}"
+ BASE_CFLAGS_FOR_BUILD="${CFLAGS}"
else
+ # passed in environment
CFLAGS_FOR_BUILD=${CFLAGS-'$(CFLAGS)'}
+ BASE_CFLAGS_FOR_BUILD=${CFLAGS-'$(CFLAGS)'}
fi
LIBS_FOR_BUILD=${LIBS_FOR_BUILD-'$(LIBS)'}
else
@@ -526,6 +529,7 @@ else
CPPFLAGS_FOR_BUILD=${CPPFLAGS_FOR_BUILD-""}
LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-""}
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD="-g"}
+ BASE_CFLAGS_FOR_BUILD=${BASE_CFLAGS_FOR_BUILD="-g"}
LIBS_FOR_BUILD=${LIBS_FOR_BUILD-""}
fi
@@ -536,6 +540,8 @@ AC_SUBST(STATIC_LD)
AC_SUBST(CC_FOR_BUILD)
AC_SUBST(CFLAGS_FOR_BUILD)
+AC_SUBST(BASE_CFLAGS_FOR_BUILD)
+AC_SUBST(STYLE_CFLAGS)
AC_SUBST(CPPFLAGS_FOR_BUILD)
AC_SUBST(LDFLAGS_FOR_BUILD)
AC_SUBST(LIBS_FOR_BUILD)
@@ -1208,7 +1214,7 @@ mips-pyramid-sysv4) LOCAL_CFLAGS=-Xa ;;
esac
# turn off paren warnings in gcc
-CFLAGS="$CFLAGS ${STYLE_CFLAGS}"
+#CFLAGS="$CFLAGS ${STYLE_CFLAGS}"
#
# Shared object configuration section. These values are generated by