summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJari Aalto <jari.aalto@cante.net>2001-11-13 17:56:06 +0000
committerJari Aalto <jari.aalto@cante.net>2009-09-12 16:46:54 +0000
commitf73dda092b33638d2d5e9c35375f687a607b5403 (patch)
treef21584e70a444d6a1ecba0fb5e2cf79e8cce91db /configure.in
parent28ef6c316f1aff914bb95ac09787a3c83c1815fd (diff)
downloadbash-f73dda092b33638d2d5e9c35375f687a607b5403.tar.gz
Imported from ../bash-2.05a.tar.gz.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in279
1 files changed, 184 insertions, 95 deletions
diff --git a/configure.in b/configure.in
index 72134e1e..bb80193f 100644
--- a/configure.in
+++ b/configure.in
@@ -5,17 +5,37 @@ dnl report bugs to chet@po.cwru.edu
dnl
dnl Process this file with autoconf to produce a configure script.
-dnl checks for version info
-AC_REVISION([for Bash 2.05, version 2.90, from autoconf version] AC_ACVERSION)dnl
+# Copyright (C) 1987-2001 Free Software Foundation, Inc.
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+# 02111-1307, USA.
-AC_INIT(shell.h)
-AC_CONFIG_HEADER(config.h)
+AC_REVISION([for Bash 2.05a, version 2.128, from autoconf version] AC_ACVERSION)dnl
+
+AC_INIT(bash, 2.05a, bug-bash@gnu.org)
dnl make sure we are using a recent autoconf version
-AC_PREREQ(2.12)
+AC_PREREQ(2.50)
+AC_CONFIG_SRCDIR(shell.h)
dnl where to find install.sh, config.sub, and config.guess
AC_CONFIG_AUX_DIR(./support)
+AC_CONFIG_HEADERS(config.h)
+
+dnl checks for version info
+BASHVERS=2.05a
dnl canonicalize the host and os so we can do some tricky things before
dnl parsing options
@@ -23,7 +43,6 @@ AC_CANONICAL_HOST
dnl configure defaults
opt_bash_malloc=yes
-opt_glibc_malloc=no
opt_purify=no
opt_purecov=no
opt_afs=no
@@ -45,6 +64,7 @@ mips-irix6*) opt_bash_malloc=no ;; # needs 8-byte alignment
m68k-sysv) opt_bash_malloc=no ;; # fixes file descriptor leak in closedir
sparc-linux*) opt_bash_malloc=no ;; # sparc running linux; requires ELF
#*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
+*-openbsd*) opt_bash_malloc=no ;; # they claim it needs eight-bit alignment
*-aix*) opt_bash_malloc=no ;; # AIX machines
*-nextstep*) opt_bash_malloc=no ;; # NeXT machines running NeXTstep
*-macos*) opt_bash_malloc=no ;; # Apple MacOS X
@@ -64,23 +84,26 @@ dnl packages
AC_ARG_WITH(afs, --with-afs if you are running AFS, opt_afs=$withval)
AC_ARG_WITH(bash-malloc, --with-bash-malloc use the Bash version of malloc,opt_bash_malloc=$withval)
AC_ARG_WITH(curses, --with-curses use the curses library instead of the termcap library,opt_curses=$withval)
-AC_ARG_WITH(glibc-malloc, --with-glibc-malloc use the GNU C library version of malloc,opt_glibc_malloc=$withval)
AC_ARG_WITH(gnu-malloc, --with-gnu-malloc synonym for --with-bash-malloc,opt_bash_malloc=$withval)
AC_ARG_WITH(installed-readline, --with-installed-readline use a version of the readline library that is already installed, opt_with_installed_readline=$withval)
AC_ARG_WITH(purecov, --with-purecov configure to postprocess with pure coverage, opt_purecov=$withval)
AC_ARG_WITH(purify, --with-purify configure to postprocess with purify, opt_purify=$withval)
-dnl test for glibc malloc first because it can override the default
-if test "$opt_glibc_malloc" = yes; then
- MALLOC_TARGET=gmalloc
- MALLOC_SRC=gmalloc.c
-elif test "$opt_bash_malloc" = yes; then
+if test "$opt_bash_malloc" = yes; then
MALLOC_TARGET=malloc
MALLOC_SRC=malloc.c
+
+ MALLOC_LIB='-lmalloc'
+ MALLOC_LIBRARY='$(ALLOC_LIBDIR)/libmalloc.a'
+ MALLOC_LDFLAGS='-L$(ALLOC_LIBDIR)'
+ MALLOC_DEP='$(MALLOC_LIBRARY)'
+
AC_DEFINE(USING_BASH_MALLOC)
else
- MALLOC_TARGET=stubmalloc
- MALLOC_SRC=stub.c
+ MALLOC_LIB=
+ MALLOC_LIBRARY=
+ MALLOC_LDFLAGS=
+ MALLOC_DEP=
fi
if test "$opt_purify" = yes; then
@@ -126,6 +149,7 @@ opt_cond_command=yes
opt_arith_for_command=yes
opt_net_redirs=yes
opt_progcomp=yes
+opt_largefile=yes
dnl options that affect how bash is compiled and linked
opt_static_link=no
@@ -160,6 +184,7 @@ AC_ARG_ENABLE(extended-glob, --enable-extended-glob include ksh-style extended p
AC_ARG_ENABLE(help-builtin, --enable-help-builtin include the help builtin, opt_help=$enableval)
AC_ARG_ENABLE(history, --enable-history turn on command history, opt_history=$enableval)
AC_ARG_ENABLE(job-control, --enable-job-control enable job control features, opt_job_control=$enableval)
+AC_ARG_ENABLE(largefile, --enable-largefile enable support for large files, opt_largefile=$enableval)
AC_ARG_ENABLE(net-redirections, --enable-net-redirections enable /dev/tcp/host/port redirection, opt_net_redirs=$enableval)
AC_ARG_ENABLE(process-substitution, --enable-process-substitution enable process substitution, opt_process_subst=$enableval)
AC_ARG_ENABLE(progcomp, --enable-progcomp enable programmable completion and the complete builtin, opt_progcomp=$enableval)
@@ -247,22 +272,21 @@ AC_SUBST(PURIFY)
AC_SUBST(MALLOC_TARGET)
AC_SUBST(MALLOC_SRC)
-AC_SUBST(htmldir)
+AC_SUBST(MALLOC_LIB)
+AC_SUBST(MALLOC_LIBRARY)
+AC_SUBST(MALLOC_LDFLAGS)
+AC_SUBST(MALLOC_DEP)
-dnl Use GNU m4 macros to get the distribution and patchlevel information
-dnl into configure without requiring the files to be distributed
-[BASHVERS=]dnl
-esyscmd(cat _distribution)dnl
-[BASHPATCH=]dnl
-esyscmd(cat _patchlevel)dnl
+AC_SUBST(htmldir)
+echo ""
echo "Beginning configuration for bash-$BASHVERS for ${host_cpu}-${host_vendor}-${host_os}"
+echo ""
dnl compilation checks
dnl AC_PROG_CC sets $cross_compiling to `yes' if cross-compiling for a
dnl different environment
AC_PROG_CC
-BASH_LARGE_FILE_SUPPORT
dnl test for Unix variants
AC_ISC_POSIX
@@ -271,7 +295,8 @@ AC_MINIX
dnl test for non-Unix variants
AC_CYGWIN
AC_MINGW32
-AC_EXEEXT
+
+AC_SYS_LARGEFILE
dnl BEGIN changes for cross-building for cygwin and BeOS
@@ -333,10 +358,13 @@ if test "$opt_profiling" = "yes"; then
fi
if test "$opt_static_link" = yes; then
- # if we're using gcc, add `-static' to LDFLAGS
+ # if we're using gcc, add `-static' to LDFLAGS, except on Solaris >= 2
if test -n "$GCC" || test "$ac_cv_prog_gcc" = "yes"; then
- STATIC_LD="-static"
- LDFLAGS="$LDFLAGS -static" # XXX experimental
+ STATIC_LD="-static"
+ case "$host_os" in
+ solaris2*) ;;
+ *) LDFLAGS="$LDFLAGS -static" ;; # XXX experimental
+ esac
fi
fi
@@ -351,40 +379,33 @@ dnl BEGIN READLINE and HISTORY LIBRARY SECTION
dnl prepare to allow bash to be linked against an already-installed readline
dnl first test that the readline version is new enough to link bash against
-if test "$opt_readline" = yes && test "$opt_with_installed_readline" = "yes"
+if test "$opt_readline" = yes && test "$opt_with_installed_readline" != "no"
then
+echo opt_with_installed_readline = $opt_with_installed_readline
+ # If the user specified --with-installed-readline=PREFIX and PREFIX
+ # is not `yes', set ac_cv_rl_prefix to PREFIX
+ test $opt_with_installed_readline != "yes" && ac_cv_rl_prefix=$opt_with_installed_readline
-dnl we duplicate some work that's done later here so we can look in
-dnl the correct directory for the readline library
-
- if test -z "$TERMCAP_LIB" ; then
- BASH_CHECK_LIB_TERMCAP
- fi
-
- test "x$prefix" = xNONE && _rl_prefix=$ac_default_prefix || _rl_prefix=${prefix}
- test "x$exec_prefix" = xNONE && _rl_exec_prefix=${_rl_prefix} || _rl_exec_prefix=${exec_prefix}
-
- AC_MSG_CHECKING(version of installed readline library)
- _rl_version=`exec_prefix=${_rl_exec_prefix} ${CONFIG_SHELL-/bin/sh} ${srcdir}/support/rlvers.sh -C "${CC}" -L ${libdir} -I ${includedir} -T ${TERMCAP_LIB}`
- AC_MSG_RESULT($_rl_version)
+ RL_LIB_READLINE_VERSION
- case "$_rl_version" in
+ case "$ac_cv_rl_version" in
4.[[2-9]]*|5*|6*|7*|8*|9*) ;;
*) opt_with_installed_readline=no
AC_MSG_WARN(installed readline library is too old to be linked with bash)
AC_MSG_WARN(using private bash version)
;;
esac
- unset _rl_version _rl_prefix _rl_exec_prefix
fi
if test $opt_readline = yes; then
AC_DEFINE(READLINE)
READLINE_LIB=-lreadline
- if test "$opt_with_installed_readline" = "yes" ; then
- RL_LIBDIR='$(libdir)'
+ if test "$opt_with_installed_readline" != "no" ; then
+ case "$RL_INCLUDEDIR" in
+ /usr/include) ;;
+ *) RL_INCLUDE='-I${RL_INCLUDEDIR}'
+ esac
READLINE_DEP=
- RL_INCLUDE='-I$(includedir)'
else
RL_LIBDIR='$(dot)/$(LIBSUBDIR)/readline'
READLINE_DEP='$(READLINE_LIBRARY)'
@@ -401,10 +422,13 @@ if test $opt_history = yes || test $opt_bang_history = yes; then
AC_DEFINE(BANG_HISTORY)
fi
HISTORY_LIB=-lhistory
- if test "$opt_with_installed_readline" = "yes"; then
- HIST_LIBDIR='$(libdir)'
+ if test "$opt_with_installed_readline" != "no"; then
+ HIST_LIBDIR=$RL_LIBDIR
HISTORY_DEP=
- RL_INCLUDE='-I$(includedir)'
+ case "$RL_INCLUDEDIR" in
+ /usr/include) ;;
+ *) RL_INCLUDE='-I${RL_INCLUDEDIR}'
+ esac
else
HIST_LIBDIR='$(dot)/$(LIBSUBDIR)/readline'
HISTORY_DEP='$(HISTORY_LIBRARY)'
@@ -416,6 +440,7 @@ fi
AC_SUBST(READLINE_LIB)
AC_SUBST(READLINE_DEP)
AC_SUBST(RL_LIBDIR)
+AC_SUBST(RL_INCLUDEDIR)
AC_SUBST(RL_INCLUDE)
AC_SUBST(HISTORY_LIB)
AC_SUBST(HISTORY_DEP)
@@ -425,7 +450,7 @@ dnl END READLINE and HISTORY LIBRARY SECTION
dnl programs needed by the build and install process
AC_PROG_INSTALL
-AC_CHECK_PROG(AR, ar, ar)
+AC_CHECK_PROG(AR, ar, , ar)
dnl Set default for ARFLAGS, since autoconf does not have a macro for it.
dnl This allows people to set it when running configure or make
test -n "$ARFLAGS" || ARFLAGS="cr"
@@ -439,14 +464,52 @@ opennt*|interix*) MAKE_SHELL="$INTERIX_ROOT/bin/sh" ;;
esac
AC_SUBST(MAKE_SHELL)
+dnl Turn on any extensions available in the GNU C library.
+AC_DEFINE(_GNU_SOURCE, 1)
+
+dnl C compiler characteristics
+AC_C_CONST
+AC_C_INLINE
+AC_C_BIGENDIAN
+AC_C_STRINGIZE
+AC_C_LONG_DOUBLE
+AC_C_PROTOTYPES
+AC_C_CHAR_UNSIGNED
+
+dnl header files
+AC_HEADER_DIRENT
+AC_HEADER_TIME
+
+BASH_HEADER_INTTYPES
+
+AC_CHECK_HEADERS(unistd.h stdlib.h stdarg.h varargs.h limits.h string.h \
+ memory.h locale.h termcap.h termio.h termios.h dlfcn.h \
+ stddef.h stdint.h netdb.h grp.h strings.h)
+AC_CHECK_HEADERS(sys/ptem.h sys/pte.h sys/stream.h sys/select.h sys/file.h \
+ sys/resource.h sys/param.h sys/socket.h \
+ sys/time.h sys/times.h sys/wait.h)
+AC_CHECK_HEADERS(netinet/in.h arpa/inet.h)
+
dnl special checks for libc functions
AC_FUNC_ALLOCA
AC_FUNC_GETPGRP
AC_FUNC_SETVBUF_REVERSED
AC_FUNC_VPRINTF
-AC_FUNC_WAIT3
AC_FUNC_STRCOLL
+dnl if we're not using the bash malloc but require the C alloca, set things
+dnl up to build a libmalloc.a containing only alloca.o
+
+if test "$ac_cv_func_alloca_works" = "no" && test "$opt_bash_malloc" = "no"; then
+ MALLOC_TARGET=alloca
+ MALLOC_SRC=alloca.c
+
+ MALLOC_LIB='-lmalloc'
+ MALLOC_LIBRARY='$(ALLOC_LIBDIR)/libmalloc.a'
+ MALLOC_LDFLAGS='-L$(ALLOC_LIBDIR)'
+ MALLOC_DEP='$(MALLOC_LIBRARY)'
+fi
+
dnl if vprintf is not in libc, see if it's defined in stdio.h
if test "$ac_cv_func_vprintf" = no; then
AC_MSG_CHECKING(for declaration of vprintf in stdio.h)
@@ -457,8 +520,12 @@ if test "$ac_cv_func_vprintf" = no; then
fi
fi
+if test "$ac_cv_func_vprintf" = no && test "$ac_cv_func__doprnt" = "yes"; then
+ AC_LIBOBJ(vprint)
+fi
+
dnl signal stuff
-AC_RETSIGTYPE
+AC_TYPE_SIGNAL
dnl checks for certain version-specific system calls and libc functions
AC_CHECK_FUNC(__setostype, AC_DEFINE(HAVE_SETOSTYPE))
@@ -471,14 +538,31 @@ dnl checks for system calls
AC_CHECK_FUNCS(dup2 select getdtablesize getgroups gethostname \
setdtablesize getpagesize killpg lstat getpeername sbrk \
getrlimit getrusage gettimeofday waitpid tcgetpgrp \
- readlink rename)
+ readlink)
+AC_REPLACE_FUNCS(rename)
dnl checks for c library functions
-AC_CHECK_FUNCS(bcopy bzero confstr getcwd strcasecmp setenv putenv \
- setlinebuf setlocale strchr strerror strtod strtol \
- strtoul tcgetattr uname sysconf ulimit times tzset \
- siginterrupt memmove ttyname gethostbyname getservbyname \
- inet_aton strpbrk setvbuf pathconf)
+AC_CHECK_FUNCS(bcopy bzero confstr sysconf pathconf setenv putenv \
+ setlinebuf setvbuf setlocale strchr tcgetattr uname \
+ ulimit tzset siginterrupt memmove ttyname times \
+ getaddrinfo gethostbyname getservbyname inet_aton \
+ vsnprintf snprintf vasprintf asprintf fnmatch)
+AC_CHECK_FUNCS(isascii isblank isgraph isprint isspace isxdigit)
+AC_REPLACE_FUNCS(getcwd strcasecmp strerror strpbrk strtod)
+AC_REPLACE_FUNCS(strtol strtoul strtoll strtoull strtoimax strtoumax)
+
+AC_CHECK_DECLS([strtold])
+AC_CHECK_DECLS([confstr])
+AC_CHECK_DECLS([sbrk])
+AC_CHECK_DECLS([printf])
+AC_CHECK_DECLS([strsignal])
+
+BASH_CHECK_DECL(strtoimax)
+BASH_CHECK_DECL(strtol)
+BASH_CHECK_DECL(strtoll)
+BASH_CHECK_DECL(strtoul)
+BASH_CHECK_DECL(strtoull)
+BASH_CHECK_DECL(strtoumax)
dnl checks for locale functions
AC_CHECK_HEADERS(libintl.h)
@@ -502,18 +586,6 @@ fi
dnl this defines SYS_SIGLIST_DECLARED
AC_DECL_SYS_SIGLIST
-dnl header files
-AC_HEADER_DIRENT
-AC_HEADER_TIME
-
-AC_CHECK_HEADERS(unistd.h stdlib.h stdarg.h varargs.h limits.h string.h \
- memory.h locale.h termcap.h termio.h termios.h dlfcn.h \
- stddef.h netdb.h)
-AC_CHECK_HEADERS(sys/ptem.h sys/pte.h sys/stream.h sys/select.h sys/file.h \
- sys/resource.h sys/param.h sys/socket.h \
- sys/time.h sys/times.h sys/wait.h)
-AC_CHECK_HEADERS(netinet/in.h arpa/inet.h)
-
dnl network functions -- check for inet_aton again
if test "$ac_cv_func_inet_aton" != 'yes'; then
BASH_FUNC_INET_ATON
@@ -527,7 +599,7 @@ esac
dnl check for getpeername in the socket library only if it's not in libc
if test "$ac_cv_func_getpeername" = no; then
- BASH_CHECK_SOCKLIB
+ BASH_CHECK_LIB_SOCKET
fi
dnl check for gethostbyname in socket libraries if it's not in libc
if test "$ac_cv_func_gethostbyname" = no; then
@@ -541,8 +613,12 @@ AC_TYPE_MODE_T
AC_TYPE_UID_T
AC_TYPE_PID_T
AC_TYPE_SIZE_T
+AC_CHECK_TYPE(ssize_t, int)
AC_CHECK_TYPE(time_t, long)
+BASH_TYPE_LONG_LONG
+BASH_TYPE_UNSIGNED_LONG_LONG
+
AC_TYPE_SIGNAL
AC_CHECK_SIZEOF(char, 1)
@@ -551,9 +627,10 @@ AC_CHECK_SIZEOF(int, 4)
AC_CHECK_SIZEOF(long, 4)
AC_CHECK_SIZEOF(char *, 4)
AC_CHECK_SIZEOF(double, 8)
+AC_CHECK_SIZEOF([long long], 8)
-AC_CHECK_TYPE(u_int, unsigned int)
-AC_CHECK_TYPE(u_long, unsigned long)
+AC_CHECK_TYPE(u_int, [unsigned int])
+AC_CHECK_TYPE(u_long, [unsigned long])
BASH_TYPE_BITS16_T
BASH_TYPE_U_BITS16_T
@@ -566,16 +643,11 @@ BASH_TYPE_PTRDIFF_T
dnl structures
AC_HEADER_STAT
-dnl C compiler characteristics
-AC_C_BIGENDIAN
-
dnl system services
AC_SYS_INTERPRETER
if test $ac_cv_sys_interpreter = yes; then
AC_DEFINE(HAVE_HASH_BANG_EXEC)
fi
-dnl we use NO_READ_RESTART_ON_SIGNAL
-AC_SYS_RESTARTABLE_SYSCALLS
dnl Miscellaneous Bash tests
if test "$ac_cv_func_lstat" = "no"; then
@@ -583,13 +655,9 @@ BASH_FUNC_LSTAT
fi
dnl behavior of system calls and library functions
-BASH_DUP2_CLOEXEC_CHECK
-BASH_PGRP_SYNC
-BASH_SIGNAL_CHECK
-
-if test "$ac_cv_sys_restartable_syscalls" = "no"; then
-BASH_SYS_RESTARTABLE_SYSCALLS
-fi
+BASH_FUNC_DUP2_CLOEXEC_CHECK
+BASH_SYS_PGRP_SYNC
+BASH_SYS_SIGNAL_VINTAGE
dnl checking for the presence of certain library symbols
BASH_SYS_ERRLIST
@@ -601,7 +669,12 @@ BASH_TYPE_SIGHANDLER
BASH_CHECK_TYPE(clock_t, [#include <sys/times.h>], long)
BASH_CHECK_TYPE(sigset_t, [#include <signal.h>], int)
BASH_CHECK_TYPE(quad_t, , long, HAVE_QUAD_T)
-BASH_RLIMIT_TYPE
+BASH_CHECK_TYPE(intmax_t, , $bash_cv_type_long_long)
+BASH_CHECK_TYPE(uintmax_t, , $bash_cv_type_unsigned_long_long)
+if test "$ac_cv_header_sys_socket_h" = "yes"; then
+BASH_CHECK_TYPE(socklen_t, [#include <sys/socket.h>], int, HAVE_SOCKLEN_T)
+fi
+BASH_TYPE_RLIMIT
dnl presence and contents of structures used by system calls
BASH_STRUCT_TERMIOS_LDISC
@@ -610,36 +683,52 @@ BASH_STRUCT_DIRENT_D_INO
BASH_STRUCT_DIRENT_D_FILENO
BASH_STRUCT_WINSIZE
BASH_STRUCT_TIMEVAL
+AC_CHECK_MEMBERS([struct stat.st_blocks])
dnl presence and behavior of C library functions
BASH_FUNC_STRSIGNAL
BASH_FUNC_OPENDIR_CHECK
-BASH_FUNC_PRINTF
BASH_FUNC_ULIMIT_MAXFDS
BASH_FUNC_GETENV
+if test "$ac_func_getcwd" = "yes"; then
BASH_FUNC_GETCWD
-BASH_FUNC_SBRK_DECLARED
+fi
BASH_FUNC_POSIX_SETJMP
BASH_FUNC_STRCOLL
+dnl I have removed this check. The existing libc FNM_EXTMATCH implementation
+dnl (glibc-2.2.4) disagrees with bash on the matching of incorrectly-formed
+dnl patterns (bash treats them as strings or characters to be matched without
+dnl any special meaning) and has one outright bug: a[X-]b should match
+dnl both a-b and aXb.
+dnl
+dnl Once Ulrich and I get together on this, the check can return
+dnl
+dnl chet 10/31/2001
+dnl
+dnl BASH_FUNC_FNMATCH_EXTMATCH
+
+BASH_FUNC_PRINTF_A_FORMAT
+
dnl presence and behavior of OS functions
-BASH_REINSTALL_SIGHANDLERS
-BASH_JOB_CONTROL_MISSING
+BASH_SYS_REINSTALL_SIGHANDLERS
+BASH_SYS_JOB_CONTROL_MISSING
BASH_SYS_NAMED_PIPES
dnl presence of certain CPP defines
-BASH_HAVE_TIOCGWINSZ
+AC_HEADER_TIOCGWINSZ
BASH_HAVE_TIOCSTAT
BASH_HAVE_FIONREAD
dnl miscellaneous
-BASH_MISC_SPEED_T
+BASH_CHECK_SPEED_T
BASH_CHECK_GETPW_FUNCS
BASH_CHECK_RTSIGS
+BASH_CHECK_SYS_SIGLIST
dnl special checks
case "$host_os" in
-hpux*) BASH_KERNEL_RLIMIT_CHECK ;;
+hpux*) BASH_CHECK_KERNEL_RLIMIT ;;
esac
if test "$opt_readline" = yes; then
@@ -654,7 +743,7 @@ AC_SUBST(TERMCAP_DEP)
BASH_CHECK_DEV_FD
BASH_CHECK_DEV_STDIN
-BASH_DEFAULT_MAIL_DIR
+BASH_SYS_DEFAULT_MAIL_DIR
if test "$bash_cv_job_control_missing" = missing; then
opt_job_control=no
@@ -689,6 +778,7 @@ hpux*) LOCAL_CFLAGS=-DHPUX ;;
dgux*) LOCAL_CFLAGS=-D_DGUX_SOURCE; LOCAL_LIBS=-ldgc ;;
isc*) LOCAL_CFLAGS=-Disc386 ;;
rhapsody*) LOCAL_CFLAGS=-DRHAPSODY ;;
+darwin*) LOCAL_CFLAGS=-DMACOSX ;;
sco3.2v5*) LOCAL_CFLAGS="-b elf -DWAITPID_BROKEN -DNO_MEMSCRAMBLE -DPATH_MAX=1024" ;;
sco3.2v4*) LOCAL_CFLAGS="-DMUST_UNBLOCK_CHLD -DNO_MEMSCRAMBLE -DPATH_MAX=1024" ;;
sco3.2*) LOCAL_CFLAGS=-DMUST_UNBLOCK_CHLD ;;
@@ -699,7 +789,7 @@ linux*) LOCAL_LDFLAGS=-rdynamic ;; # allow dynamic loading
*qnx*) LOCAL_CFLAGS="-Dqnx -F -3s" LOCAL_LDFLAGS="-3s -lunix -lncurses" ;;
powerux*) LOCAL_LIBS="-lgen" ;;
cygwin*) LOCAL_LIBS="-luser32" ;;
-opennt*|interix*) LOCAL_CFLAGS="-DNO_MAIN_ENV_ARG" ;;
+opennt*|interix*) LOCAL_CFLAGS="-DNO_MAIN_ENV_ARG -DBROKEN_DIRENT_D_INO" ;;
esac
dnl Stanza for OS/compiler pair-specific flags
@@ -776,7 +866,6 @@ AC_SUBST(AR)
AC_SUBST(ARFLAGS)
AC_SUBST(BASHVERS)
-AC_SUBST(BASHPATCH)
AC_SUBST(host_cpu)
AC_SUBST(host_vendor)