summaryrefslogtreecommitdiff
path: root/dc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dc/Makefile.am')
-rw-r--r--dc/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/dc/Makefile.am b/dc/Makefile.am
new file mode 100644
index 0000000..99164ba
--- /dev/null
+++ b/dc/Makefile.am
@@ -0,0 +1,14 @@
+## Process this file with automake to produce Makefile.in
+bin_PROGRAMS = dc
+
+dc_SOURCES = dc.c misc.c eval.c stack.c array.c numeric.c string.c
+noinst_HEADERS = dc.h dc-proto.h dc-regdef.h
+
+INCLUDES = -I$(srcdir)/.. -I$(srcdir)/../h
+LDADD = ../lib/libbc.a
+
+MAINTAINERCLEANFILES = Makefile.in
+
+CFLAGS = @CFLAGS@ -Wall -funsigned-char
+
+$(PROGRAMS): $(LDADD)