summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2021-07-26 00:27:02 +0300
committerIvan Maidanski <ivmai@mail.ru>2021-07-26 00:27:02 +0300
commit06e4efff9949a670d41e4455ca1d4eee3d9ba58c (patch)
treedd7b2478380b2e681be0ee27c3b60a30f2b5e7c9 /CMakeLists.txt
parentabf191cbf9a6d7608ee6afa3b8b900c06f2f047b (diff)
downloadbdwgc-06e4efff9949a670d41e4455ca1d4eee3d9ba58c.tar.gz
Install gc_gcj.h and gc_pthread_redirects.h only if appropriate
gc_gcj.h should not be installed if support for gcj is off. gc_pthread_redirects.h should not be installed if threads support is off or not based on pthread library. * CMakeLists.txt [install_headers] (FILES): Install include/gc_gcj.h only if enable_gcj_support; install include/gc_pthread_redirects.h only if enable_threads AND CMAKE_USE_PTHREADS_INIT. * Makefile.am (libgc_la_SOURCES): Remove gcj_mlc.c unless ENABLE_GCJ_SUPPORT. * Makefile.am [PTHREADS] (pkginclude_HEADERS): Add include/gc_pthread_redirects.h. * Makefile.am [ENABLE_GCJ_SUPPORT] (pkginclude_HEADERS): Add include/gc_gcj.h. * configure.ac (ENABLE_GCJ_SUPPORT): New AM conditional. * include/include.am (pkginclude_HEADERS): Remove gc_gcj.h and gc_pthread_redirects.h.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1aa0c4b6..282c8b1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -551,10 +551,8 @@ if (install_headers)
install(FILES include/gc.h
include/gc_backptr.h
include/gc_config_macros.h
- include/gc_gcj.h
include/gc_inline.h
include/gc_mark.h
- include/gc_pthread_redirects.h
include/gc_tiny_fl.h
include/gc_typed.h
include/gc_version.h
@@ -573,6 +571,14 @@ if (install_headers)
install(FILES include/gc_disclaim.h
DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/gc")
endif()
+ if (enable_gcj_support)
+ install(FILES include/gc_gcj.h
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/gc")
+ endif()
+ if (enable_threads AND CMAKE_USE_PTHREADS_INIT)
+ install(FILES include/gc_pthread_redirects.h
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/gc")
+ endif()
if (build_cord)
install(FILES include/cord.h
include/cord_pos.h