summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSteve Youngs <steve@sxemacs.org>2021-07-10 00:27:44 +0300
committerIvan Maidanski <ivmai@mail.ru>2021-07-10 10:03:26 +0300
commit292d98e0bec23861193fbf1401d610a8e2e808c4 (patch)
tree396e4473031808aa5578cbbb505095f3ce72fd63 /CMakeLists.txt
parente2ddc434f0cfae00e72a8362a73085e6cf9e1570 (diff)
downloadbdwgc-292d98e0bec23861193fbf1401d610a8e2e808c4.tar.gz
Make Libs elements space-separated in bdw-gc.pc when generated by CMake
(fix of commit fe4ed5af3) Issue #356 (bdwgc). * CMakeLists.txt [enable_threads] (THREADDLLIBS): Put the value in quotes.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 173ca445..d18674aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,9 +153,9 @@ if (enable_threads)
if (${CMAKE_DL_LIBS} MATCHES ^[^-].*)
# Some cmake versions have a broken non-empty CMAKE_DL_LIBS omitting "-l".
# Assume CMAKE_DL_LIBS contains just one library.
- set(THREADDLLIBS ${THREADDLLIBS} -l${CMAKE_DL_LIBS})
+ set(THREADDLLIBS "${THREADDLLIBS} -l${CMAKE_DL_LIBS}")
else()
- set(THREADDLLIBS ${THREADDLLIBS} ${CMAKE_DL_LIBS})
+ set(THREADDLLIBS "${THREADDLLIBS} ${CMAKE_DL_LIBS}")
endif()
endif(enable_threads)