summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2020-02-28 00:51:58 +0300
committerIvan Maidanski <ivmai@mail.ru>2020-02-28 00:51:58 +0300
commit4221a155e0d9111c6aabfbbbb0c969069935ba1f (patch)
treeb93df1ba8c88844a20cd99469eaab224257a2b41 /CMakeLists.txt
parent1dc3d9e2bc8c021ff1d12309e052acd5e5a4915f (diff)
downloadbdwgc-4221a155e0d9111c6aabfbbbb0c969069935ba1f.tar.gz
New CMake option (disable_gc_debug) to remove debugging code
This is similar to configure --disable-gc-debug. * CMakeLists.txt (disable_gc_debug): New option. * CMakeLists.txt [disable_gc_debug] (NO_DEBUGGING): Define macro.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7ac9ced..61ead373 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,6 +49,7 @@ option(enable_throw_bad_alloc_library "Turn on C++ gctba library build" ON)
option(enable_gcj_support "Support for gcj" ON)
option(enable_sigrt_signals "Use SIGRTMIN-based signals for thread suspend/resume" OFF)
option(enable_gc_debug "Support for pointer back-tracing" OFF)
+option(disable_gc_debug "Disable debugging like GC_dump and its callees" OFF)
option(enable_java_finalization "Support for java finalization" ON)
option(enable_atomic_uncollectable "Support for atomic uncollectible allocation" ON)
option(enable_redirect_malloc "Redirect malloc and friends to GC routines" OFF)
@@ -215,6 +216,10 @@ if (enable_gc_debug)
endif()
endif(enable_gc_debug)
+if (disable_gc_debug)
+ add_definitions("-DNO_DEBUGGING")
+endif()
+
if (enable_redirect_malloc)
if (enable_gc_debug)
add_definitions("-DREDIRECT_MALLOC=GC_debug_malloc_replacement")