summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2021-09-29 07:34:06 +0300
committerIvan Maidanski <ivmai@mail.ru>2021-09-29 09:37:26 +0300
commit47e9106c17b72e9ee5501308f69ea94531e798b3 (patch)
treeb5b1105af9bed13e20cae834a3ded63dba2ea858 /CMakeLists.txt
parent8abae7f37f6be7f338338c271405a74dd243aff4 (diff)
downloadbdwgc-47e9106c17b72e9ee5501308f69ea94531e798b3.tar.gz
[8.2.0]v8.2.0
Bump gc version to 8.2.0 (experimental release) * ChangeLog (8.2.0): Set release date. * CMakeLists.txt (PACKAGE_VERSION): Bump minor version and set micro to 0 (change package version to 8.2.0). * README.md: Likewise. * configure.ac (AC_INIT): Likewise. * include/gc_version.h (GC_TMP_VERSION_MINOR, GC_TMP_VERSION_MICRO): Likewise. * CMakeLists.txt (LIBGCCPP_VER_INFO): Increment current and age (change version info of libgccpp.so to 6:0:5). * Makefile.am (LIBGCCPP_VER_INFO): Likewise. * README.md: Remove build status badges (Travis, AppVeyor, Codecov, Coveralls, Coverity, LGTM). * doc/README.cmake (HOW TO IMPORT BDWGC): Update BDWgc version in the sample.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 91095d29..052e1af6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,7 +24,7 @@
cmake_minimum_required(VERSION 3.1)
-set(PACKAGE_VERSION 8.1.0)
+set(PACKAGE_VERSION 8.2.0)
# Version must match that in AC_INIT of configure.ac and that in README.
# Version must conform to: [0-9]+[.][0-9]+[.][0-9]+
@@ -32,7 +32,7 @@ set(PACKAGE_VERSION 8.1.0)
# These values should match those in cord/cord.am and Makefile.am.
set(LIBCORD_VER_INFO 5:0:4)
set(LIBGC_VER_INFO 6:0:5)
-set(LIBGCCPP_VER_INFO 5:0:4)
+set(LIBGCCPP_VER_INFO 6:0:5)
option(enable_cplusplus "C++ support" OFF)
if (enable_cplusplus)