summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2023-04-17 20:30:51 +0300
committerIvan Maidanski <ivmai@mail.ru>2023-04-17 20:30:51 +0300
commitd70772a42debc40d4c13fd735913ee6ae322aa9b (patch)
tree4d7ee6103622930fe12d60fd7ce675ef9126fc3b /CMakeLists.txt
parentba363361b19192213b612d21010d6da087d21a05 (diff)
downloadbdwgc-d70772a42debc40d4c13fd735913ee6ae322aa9b.tar.gz
Prevent 'function should return a value' BCC error in CMake script
* CMakeLists.txt [enable_werror && BORLAND && enable_threads]: Pass "/w-rvl" to add_compile_options; add comment.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9e11847..7bf50784 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -394,6 +394,11 @@ endif(enable_checksums)
if (enable_werror)
if (BORLAND)
add_compile_options(/w!)
+ if (enable_threads)
+ # Workaround "function should return a value" warning for several
+ # asm functions in atomic_ops/sysdeps/msftc/x86.h.
+ add_compile_options(/w-rvl)
+ endif(enable_threads)
elseif (MSVC)
add_compile_options(/WX)
# Workaround "typedef ignored on left of ..." warning reported in