summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2019-06-15 15:30:32 +0300
committerIvan Maidanski <ivmai@mail.ru>2019-06-15 15:30:32 +0300
commit9e5a4952dcba990ad8d7c8d30ae2eb2979d1e33e (patch)
treebc675dd1cda3efb2fcd96d69fd74a3aeb28ed72c /Makefile.am
parent227a6979555a4f2fbae81c14e9c6e3b0ef03fca8 (diff)
downloadbdwgc-9e5a4952dcba990ad8d7c8d30ae2eb2979d1e33e.tar.gz
Move test executable files produced by CMake to the base folder
Issue #281 (bdwgc). This is done by moving the content of cord/CMakeLists.txt and tests/CMakeLists.txt files to the base CMakeLists.txt. * CMakeLists.txt [build_tests && build_cord]: Move content from cord/CMakeLists.txt. * CMakeLists.txt [build_tests && build_cord] (cordtest, de): Add "cord/" to .c files in add_executable. * CMakeLists.txt [build_tests]: Move content from tests/CMakeLists.txt. * CMakeLists.txt [build_tests] (gctest, hugetest, leaktest, middletest, realloc_test, smashtest, tracetest, test_cpp, disclaim_bench, disclaim_test, disclaim_weakmap_test, disclaim_weakmap_test): Add "tests/" to .c and .cc files in add_executable. * Makefile.am (EXTRA_DIST): Remove cord/CMakeLists.txt, tests/CMakeLists.txt. * doc/README.cmake: Update info about CMakeLists.txt files (there is just one file now). * cord/CMakeLists.txt: Remove file. * tests/CMakeLists.txt: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5de2657f..fc77933c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -198,8 +198,7 @@ EXTRA_DIST += README.QUICK
# :GOTCHA: deliberately we do not include 'Makefile'
EXTRA_DIST += BCC_MAKEFILE NT_MAKEFILE \
OS2_MAKEFILE PCR-Makefile digimars.mak \
- Makefile.direct SMakefile.amiga WCC_MAKEFILE autogen.sh \
- CMakeLists.txt cord/CMakeLists.txt tests/CMakeLists.txt
+ Makefile.direct SMakefile.amiga WCC_MAKEFILE autogen.sh CMakeLists.txt
# files used by makefiles other than Makefile.am
#