summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2017-03-01 11:10:00 +0300
committerIvan Maidanski <ivmai@mail.ru>2017-03-01 11:10:00 +0300
commitc4e67b4a301bea050e5e21d606e62b3f8f4a9a01 (patch)
tree6f734a6e58ac57d701912a1339074192f0c0e14b /Makefile.am
parenta987b1ad4ac4947923d0a227fe612969971b762b (diff)
downloadbdwgc-c4e67b4a301bea050e5e21d606e62b3f8f4a9a01.tar.gz
Move libraries version info to the beginning of Makefile.am
(code refactoring) * Makefile.am (LIBGC_VER_INFO, LIBGCCPP_VER_INFO): New variable; add comment about the version update rule. * cord/cord.am (LIBCORD_VER_INFO): Likewise. * Makefile.am (libgc_la_LDFLAGS, libgccpp_la_LDFLAGS): Use LIBGC[CPP]_VER_INFO instead the direct hard-coding of version info. * cord/cord.am (libcord_la_LDFLAGS): Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8fcd1b8f..689e0bf8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,6 +11,12 @@
## Process this file with automake to produce Makefile.in.
+# Info (current:revision:age) for the Libtool versioning system.
+# These numbers should be updated at most once just before the release,
+# and, optionally, at most once during the development (after the release).
+LIBGC_VER_INFO = 1:3:0
+LIBGCCPP_VER_INFO = 1:3:0
+
## FIXME: `make distcheck' in this directory will not currently work.
## This is most likely to the explicit flags passed to submakes.
@@ -98,7 +104,8 @@ endif
# linuxthread semaphore functions get linked:
libgc_la_LIBADD = @addobjs@ $(THREADDLLIBS) $(UNWINDLIBS) $(ATOMIC_OPS_LIBS)
libgc_la_DEPENDENCIES = @addobjs@
-libgc_la_LDFLAGS = $(extra_ldflags_libgc) -version-info 1:3:0 -no-undefined
+libgc_la_LDFLAGS = $(extra_ldflags_libgc) -version-info $(LIBGC_VER_INFO) \
+ -no-undefined
EXTRA_libgc_la_SOURCES = ia64_save_regs_in_stack.s sparc_mach_dep.S \
sparc_netbsd_mach_dep.s sparc_sunos4_mach_dep.s
@@ -113,7 +120,7 @@ pkginclude_HEADERS += include/gc_cpp.h
include_HEADERS += include/extra/gc_cpp.h
libgccpp_la_SOURCES = gc_cpp.cc
libgccpp_la_LIBADD = ./libgc.la
-libgccpp_la_LDFLAGS = -version-info 1:3:0 -no-undefined
+libgccpp_la_LDFLAGS = -version-info $(LIBGCCPP_VER_INFO) -no-undefined
endif
# FIXME: If Visual C++ users use Makefile.am, this should go into