summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2021-11-25 21:12:43 +0300
committerIvan Maidanski <ivmai@mail.ru>2021-11-25 21:12:43 +0300
commitdff23b50b747cba4b46285b1f2ad257f52662f20 (patch)
treed2bb20421c19a757551839a8fa32f1a26af0be9b /Makefile.am
parent1a2f8b0f6e30ae997e88963a0f7b038bcabc6afb (diff)
downloadbdwgc-dff23b50b747cba4b46285b1f2ad257f52662f20.tar.gz
Remove commented out code in Makefile.am
(refactoring) * Makefile.am: Remove commented out code; adjust outdated comment near the deleted commented out code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 1 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index fb3441c1..a8f690c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,16 +21,9 @@ LIBGCCPP_VER_INFO = 6:0:5
## This is most likely to the explicit flags passed to submakes.
# We currently use the source files directly from libatomic_ops, if we
-# use the internal version. This is done since libatomic_ops doesn't
-# use libtool, since it has no real use for it. But that seems to make
-# it hard to use either the resulting object files or libraries.
+# use the internal version.
# Thus there seems to be no real reason to recursively build in the
# libatomic_ops directory.
-# if USE_INTERNAL_LIBATOMICS_OPS
-# SUBDIRS = @maybe_libatomic_ops@
-# else
-# SUBDIRS =
-# endif
SUBDIRS =
ACLOCAL_AMFLAGS = -I m4
@@ -163,13 +156,6 @@ CXXFLAGS += $(CFLAGS_EXTRA)
## FIXME: relies on internal code generated by automake.
## FIXME: ./configure --enable-dependency-tracking should be used
-#all_objs = @addobjs@ $(libgc_la_OBJECTS)
-#$(all_objs) : include/private/gcconfig.h include/private/gc_priv.h \
-#include/private/gc_hdrs.h include/gc.h include/gc_gcj.h \
-#include/gc_pthread_redirects.h include/gc_config_macros.h \
-#include/private/thread_local_alloc.h include/private_support.h \
-#include/private/pthread_stop_world.h \
-#include/gc_mark.h @addincludes@
## FIXME: we shouldn't have to do this, but automake forces us to.
## We use -Wp,-P to strip #line directives. Irix `as' chokes on