summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2021-07-26 00:27:02 +0300
committerIvan Maidanski <ivmai@mail.ru>2021-07-26 00:27:02 +0300
commit06e4efff9949a670d41e4455ca1d4eee3d9ba58c (patch)
treedd7b2478380b2e681be0ee27c3b60a30f2b5e7c9 /configure.ac
parentabf191cbf9a6d7608ee6afa3b8b900c06f2f047b (diff)
downloadbdwgc-06e4efff9949a670d41e4455ca1d4eee3d9ba58c.tar.gz
Install gc_gcj.h and gc_pthread_redirects.h only if appropriate
gc_gcj.h should not be installed if support for gcj is off. gc_pthread_redirects.h should not be installed if threads support is off or not based on pthread library. * CMakeLists.txt [install_headers] (FILES): Install include/gc_gcj.h only if enable_gcj_support; install include/gc_pthread_redirects.h only if enable_threads AND CMAKE_USE_PTHREADS_INIT. * Makefile.am (libgc_la_SOURCES): Remove gcj_mlc.c unless ENABLE_GCJ_SUPPORT. * Makefile.am [PTHREADS] (pkginclude_HEADERS): Add include/gc_pthread_redirects.h. * Makefile.am [ENABLE_GCJ_SUPPORT] (pkginclude_HEADERS): Add include/gc_gcj.h. * configure.ac (ENABLE_GCJ_SUPPORT): New AM conditional. * include/include.am (pkginclude_HEADERS): Remove gc_gcj.h and gc_pthread_redirects.h.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a908d530..eb0b582c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -678,7 +678,6 @@ dnl Interface Selection
dnl -------------------
dnl
dnl By default, make the library as general as possible.
-dnl enable_gcj_support=no
AC_ARG_ENABLE(gcj-support,
[AS_HELP_STRING([--disable-gcj-support], [disable support for gcj])])
if test x"$enable_gcj_support" != xno; then
@@ -697,6 +696,7 @@ if test x"$enable_gcj_support" != xno; then
;;
esac
fi
+AM_CONDITIONAL(ENABLE_GCJ_SUPPORT, [test x"enable_gcj_support" != xno])
dnl Interaction with other programs that might use signals.
AC_ARG_ENABLE(sigrt-signals,